Download it now!
Bug 132866 - Unable to sign an existing pdf
Summary: Unable to sign an existing pdf
Status: RESOLVED DUPLICATE of bug 130354
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.4.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-09 03:30 UTC by Lucas Barros
Modified: 2020-06-04 07:07 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lucas Barros 2020-05-09 03:30:37 UTC
Description:
I'm able to sign an odt document and even export it with the digital signature, but signing an existing pdf doesn't work.

Steps to Reproduce:
1.File
2.Signatures
3.Sign existing pdf
4.Sign document

Actual Results:
I get a dialog informing that a tmp file doesn't exist:
/home/lucas/Downloads/lu10822zfq4y.tmp doesn't exist.

Expected Results:
The pdf should have been signed.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
The pdf should have been signed.
Comment 1 ian 2020-05-11 13:52:50 UTC
Thanks for reporting this bug, Lucas.

Please attach a sample PDF, as this makes it easier for us to verify the bug. 

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.

(Note that the attachment will be public, remove any sensitive information before attaching it.)
Comment 2 Timur 2020-05-20 13:45:55 UTC
PDF sign works with X509 and not with  GPG/OpenPGP, which is yours certificate?
Comment 3 Timur 2020-06-04 07:07:47 UTC

*** This bug has been marked as a duplicate of bug 130354 ***