Bug 132894 - Removal of formatting inconsistency
Summary: Removal of formatting inconsistency
Status: RESOLVED DUPLICATE of bug 62325
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Formatting-Text-Diverse
  Show dependency treegraph
 
Reported: 2020-05-09 21:21 UTC by Telesto
Modified: 2020-09-15 21:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (8.40 KB, application/vnd.oasis.opendocument.text)
2020-05-11 11:32 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-05-09 21:21:04 UTC
Description:
Removal of formatting inconsistency

Steps to Reproduce:
1. Open the attached file
2. Set the cursor before q of quiet
3. press CTRL+SHIFT+ARROW & Backspace.
4. Type something.. no formatting
5. Undo everything
6. Double click heard & press backspace or delete & type something.. formatting
7. undo everything
8. Place the cursor before q of quiet and press backspace until heard is gone.. type something.. formatting
9. Select section before quite until he with the mouse and backspace or CTRL+X.. formatting gone

Actual Results:
Some inconsistency

Expected Results:
Consistency


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.0.0.alpha0+ (x64)
Build ID: 97a2c1fc5e376c0c00968f17a0392c6d3a5ed565
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2020-05-11 11:02:38 UTC
No attached file
Comment 2 Telesto 2020-05-11 11:32:01 UTC
Created attachment 160659 [details]
Example file
Comment 3 Thomas Lendo 2020-09-15 20:10:28 UTC
I don't think this is a bug. The formatting still exists in step 8, not visible as character but as formatting in the "non-space" between "q"(uiet) and the space before that word. It's the remnant of the formatting of "heard".

The formatting is there as long as you don't move the cursor caret away from the place where the last formatted character was deleted.

Maybe a duplicate of bug 62325 or of another issue in meta bug 127250?

Otherwise a NOTABUG for me.
Comment 4 Telesto 2020-09-15 21:56:20 UTC

*** This bug has been marked as a duplicate of bug 62325 ***