Bug 132904 - Lost New Gallery Stuff in 7.0
Summary: Lost New Gallery Stuff in 7.0
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Heiko Tietze
URL:
Whiteboard: target:7.1.0 target:7.0.0.1
Keywords:
: 132903 133777 (view as bug list)
Depends on:
Blocks: Gallery_7.0
  Show dependency treegraph
 
Reported: 2020-05-10 08:32 UTC by Rizal Muttaqin
Modified: 2020-07-20 14:41 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Notice there are just two categories left (8.83 KB, image/png)
2020-05-10 08:32 UTC, Rizal Muttaqin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rizal Muttaqin 2020-05-10 08:32:16 UTC
Created attachment 160585 [details]
Notice there are just two categories left

From latest build master

Version: 7.0.0.0.alpha1+
Build ID: 6ba74150866d71469827de9f4f19268dfa7db137
Thread CPU: 4; OS: Linux 4.20; Render UI: baku; VCL: kf5; 
Locale: id-ID (id_ID.UTF-8); UI: id-ID
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-05-07_15:09:13
Calc: threaded

I could not find the new gallery stuff (tdf#131779) leaving just the old categories: bullets and sounds
Comment 1 Telesto 2020-05-10 08:33:41 UTC
*** Bug 132903 has been marked as a duplicate of this bug. ***
Comment 2 Telesto 2020-05-10 08:34:25 UTC
Same for MacOS
Comment 3 Telesto 2020-05-21 12:34:42 UTC
Does a profile reset help
Comment 4 andreas_k 2020-06-08 22:22:16 UTC
(In reply to Telesto from comment #3)
> Does a profile reset help

A profile reset help.
Comment 5 Heiko Tietze 2020-06-09 08:54:50 UTC
No input from UX required - despite the question if we change the gallery at all or revert changes. I wonder if we should make this ticket a duplicate of bug 57466? And make bug 133777 a duplicate of this ticket?
Comment 6 Heiko Tietze 2020-06-15 16:24:13 UTC
*** Bug 133777 has been marked as a duplicate of this bug. ***
Comment 7 Heiko Tietze 2020-06-15 16:25:29 UTC
See also bug 133777 comment 2. Patch at https://gerrit.libreoffice.org/c/core/+/96382
Comment 8 Commit Notification 2020-06-17 10:36:19 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/86b1b062cfc2768a971bb842de1c16f8646d4b4b

Resolves tdf#132904 and tdf#133788 - Gallery clean-up

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2020-06-17 14:06:38 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/a6718454e6a0ab6f7eb35c4b1f5d8234a704f554

Resolves tdf#132904 and tdf#133788 - Gallery clean-up

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 BogdanB 2020-06-24 17:33:59 UTC
Everything look ok now

Version: 7.1.0.0.alpha0+
Build ID: e69f547bce7de376a0af464c5f7af5e7d2c8784a
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-06-23_15:52:52
Calc: threaded