Bug 132941 - Make other layout elements then just the "Title" and "content" editable in master slides
Summary: Make other layout elements then just the "Title" and "content" editable in ma...
Status: RESOLVED DUPLICATE of bug 62332
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Master-Slide-View
  Show dependency treegraph
 
Reported: 2020-05-11 09:32 UTC by Callegar
Modified: 2022-04-05 10:42 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Callegar 2020-05-11 09:32:53 UTC
This is an enhancement request, but could be a useful one for those using impress.

Currently, in master slide mode, one can only edit the "Title, content" layout. Would be extremely useful to be able to edit the other layouts too, such as the "Title Slide", the "Title and 2 columns", etc. For instance, one may want to set the position of the columns in the two column layout, or to change the relative frame proportions in the "Title, 2 content and content" layout, etc.

This may even be a piece of functionality that was already on the drawing board of the original developers of StarOffice and never got completed. In fact, StarOffice, Openoffice and LibO all contain "elements" that hint at it.

For once, the editing of the individual layouts is possible in MS Office and seems to be retained to some extent when one imports a pptx presentation. As a consequence, the best way to obtain certain layout combinations in Impress ends up being passing through Powerpoint. Secondly, in master slide mode, the contextual menu contains a Layout entry... that points at nothing.
Comment 1 Heiko Tietze 2020-09-01 10:05:52 UTC
UI-wise I could imagine to keep the Layouts section at the sidebar resp. Slide > Layout in master mode. Not sure there is no blocker in terms of hard-coded design in the format.
Comment 2 Cor Nouws 2021-09-13 16:28:39 UTC

*** This bug has been marked as a duplicate of bug 68975 ***
Comment 3 Cor Nouws 2021-09-13 16:29:38 UTC
(sorry - wrong bug)
Comment 4 Cor Nouws 2022-04-05 10:40:23 UTC
Hi Callegar, *,

I worked on trying to untangle the various issues around layouts and master slides. There are only three categories:

=1= Make slide Layouts editable; allow to create custom slide Layouts
(see bug 78156)

=2= Allow to assign Layouts to Master Slides, effectively creating a new "Master Slide+Layout combination" for presentations in Impress
(bug 62332)

=3= Make another layout available by default
Example of that category: [FORMATTING] there is no slide layout 'Comparison' available (bug 147289)


This bug 132941 for me is a combination of 1 and 2. I think I do most right when I mark as duplicate of 62332. Hope that's OK for you.

*** This bug has been marked as a duplicate of bug 62332 ***