Bug 132963 - Navigator's Row and Column controls don't redraw after Navigator's right border moving
Summary: Navigator's Row and Column controls don't redraw after Navigator's right bord...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha1+
Hardware: All macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: Navigator
  Show dependency treegraph
 
Reported: 2020-05-11 19:01 UTC by Roman Kuznetsov
Modified: 2020-05-31 20:28 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A screenshot with a problem (39.73 KB, image/png)
2020-05-11 19:03 UTC, Roman Kuznetsov
Details
Another problem screenshot (24.03 KB, image/jpeg)
2020-05-11 19:32 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2020-05-11 19:01:44 UTC
Description:
Navigator's Row and Column controls don't redraw after Navigator's right border moving

Steps to Reproduce:
1. Open Calc
2. Open Navigator
3. Move right-left-right its right border
4. Look at Row and Column controls on top of Navigator (look at screenshot in attach)

Actual Results:
Navigator's Row and Column controls don't redraw after Navigator's right border moving

Expected Results:
Navigator's Row and Column controls look fine after Navigator's right border moving


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.0.0.alpha1+
Build ID: a406b4fc8296f125eb8e69da889ac2d119c2faaa
CPU threads: 4; OS: Mac OS X 10.15.4; UI render: default; VCL: osx; 
Locale: ru-RU (ru_RU.UTF-8); UI: en-US
Calc: threaded
Comment 1 Roman Kuznetsov 2020-05-11 19:03:37 UTC
Created attachment 160696 [details]
A screenshot with a problem
Comment 2 Roman Kuznetsov 2020-05-11 19:05:25 UTC
Caolan, possibly you can look at it?
Comment 3 Roman Kuznetsov 2020-05-11 19:32:46 UTC
Created attachment 160699 [details]
Another problem screenshot

There is another problem in these controls - if you try increase row/column number using these controls then numbers and letters inside don't redraw too
Comment 4 Caolán McNamara 2020-05-11 20:09:32 UTC
Is this only happening under macOS ? It seems fine under the Linux gen vclplug ?
Is there a similar problem in the writer navigator or is it just the calc one ?
Comment 5 Buovjaga 2020-05-12 08:12:28 UTC
No repro on Win or any of the Linux backends with master.
Comment 6 Xisco Faulí 2020-05-14 17:33:00 UTC
I can't reproduce it in

Version: 7.0.0.0.alpha0+
Build ID: 894c0806328627aadd1e92c8601a5858a3ea627f
CPU threads: 8; OS: Mac OS X 10.14.6; UI render: default; VCL: osx; 
Locale: en-US (en_ES.UTF-8); UI-Language: en-US
Calc: threaded

maybe it's too old build
Comment 7 Caolán McNamara 2020-05-18 11:32:55 UTC
I don't see the specific problem on redraw on resize, but I do see the problem of comment #3, but I also see that problem everywhere in libreoffice in spinbuttons, e.g. in format page, margins etc
Comment 8 Xisco Faulí 2020-05-22 11:02:35 UTC
Hi Roman,
Could you please try again with the latest daily build with a clean profile ?
Comment 9 Roman Kuznetsov 2020-05-29 20:12:37 UTC
(In reply to Xisco Faulí from comment #8)
> Hi Roman,
> Could you please try again with the latest daily build with a clean profile ?

the same problem is still here in

Version: 7.1.0.0.alpha0+
Build ID: 651844c9b122fd8463ad1dde4f9a0200efc345a3
CPU threads: 4; OS: Mac OS X 10.15.4; UI render: default; VCL: osx
Locale: ru-RU (ru_RU.UTF-8); UI: en-US
Calc: threaded

build from 29 May 2020
Comment 10 Roman Kuznetsov 2020-05-29 20:15:21 UTC
(In reply to Caolán McNamara from comment #4)
> Is this only happening under macOS ? It seems fine under the Linux gen
> vclplug ?
> Is there a similar problem in the writer navigator or is it just the calc
> one ?

It happens in Calc only. The Writer's Navigator has the same ugly control (only one) but I don't see the problem there
Comment 11 Caolán McNamara 2020-05-30 18:24:05 UTC
I bet this is the same problem as bug #133498
Comment 12 Roman Kuznetsov 2020-05-31 20:26:02 UTC
(In reply to Caolán McNamara from comment #11)
> I bet this is the same problem as bug #133498

possibly, now in

Version: 7.1.0.0.alpha0+
Build ID: 2047a5978ac8188e61da9cd3b2f40d86df5570bb
CPU threads: 4; OS: Mac OS X 10.15.4; UI render: default; VCL: osx
Locale: ru-RU (ru_RU.UTF-8); UI: en-US
Calc: threaded

from 31 May 2020 I see native macOS controls and it works fine

SO let's close it as resolved