Bug 132995 - Feature request: Insert current date dialog
Summary: Feature request: Insert current date dialog
Status: RESOLVED DUPLICATE of bug 46448
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-13 07:53 UTC by NISZ LibreOffice Team
Modified: 2020-06-14 12:02 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2020-05-13 07:53:56 UTC
Word has a nice dialog for inserting the current date/time either as plain text or a field in various date/time formats: https://support.office.com/en-us/article/insert-today-s-date-in-a-word-document-fe7c08fe-7192-44a5-ac0a-88ccd51532ab 
Currently we don’t have a similar feature, but since it is rather useful, it would be nice to have a similar feature (possibly with selecting a few favorites that can be selected from toolbar dropdown button).
The Fields dialog somewhat covers the “Insert as updating date/time field” use case, but that’s complicated, and there is nothing for the plain text use case.

Use case: When editing public administration paperwork, it is many times needed to insert $Today date, when the “paperwork” was issued to the citizen. Also it is often times needed in multiple places of the same document, doing it "manually" is both repetitive and error-prone.
Comment 1 Heiko Tietze 2020-05-13 09:49:32 UTC
We have Insert > Field > Date, which takes the number formatting from the character > properties > font > language, which can be changed per character style. 

And there is Insert > Field > More Fields > Date: Format with everything that MSO offers plus "Additional Format" allowing everything else. => WFM, agreed?
Comment 2 Dieter 2020-05-13 20:34:45 UTC
(In reply to Heiko Tietze from comment #1)
> WFM, agreed?

=> NEEDINFO
Comment 3 NISZ LibreOffice Team 2020-05-29 09:17:47 UTC
(In reply to Heiko Tietze from comment #1)
> We have Insert > Field > Date, which takes the number formatting from the
> character > properties > font > language, which can be changed per character
> style. 

The language can be changed, but the default date format for a language cannot, it is hardwired into the locale data: the "medium" type default DateFormatsKey value from locale data is used for the date fields default format, but also for the Calc default date format too.
Because of this I'd rather not change that setting at the source code level.

Which brings us back to the request of setting the default date format at the Writer (and maybe even at Calc level), per-user.
This is something we cannot do at all, if I'm not mistaken, since language settings are global for all apps.

That could happen in the Fields dialog (like Word has it with the Date and Time dialog), or in the Options - Writer/Calc/etc - General tab like the app level measurement unit settings.

If we are putting the problem this way then this request does not warrant a new dialog, only a new app level config option.

> 
> And there is Insert > Field > More Fields > Date: Format with everything
> that MSO offers plus "Additional Format" allowing everything else. => WFM,
> agreed?

Field format wise yes, everything is available. It's even present on the Standard toolbar, which is great.

But what about inserting the date/time as plain text?
- The user I talked to was not particularly adamant about having fields vs plain text, was looking more after changing the default format. 
- Still, I think selecting the Date or Time field type and the "Date (fixed)" or "Time (fixed)" option under "Select" could show an "Insert as plain text" checkbox under the "Format" list, for this particular use case.
Comment 4 Heiko Tietze 2020-06-03 12:21:04 UTC
Eike, even when this is about Writer you might have an opinion regarding locales.
Comment 5 Eike Rathke 2020-06-03 18:45:32 UTC
For being able to set application wide default date and date+time formats I could only point to a long standing RFE bug 46448 which I didn't get around to. Other than that I don't know what you're referring with "opinion regarding locales".
Comment 6 Heiko Tietze 2020-06-04 08:29:04 UTC
(In reply to Eike Rathke from comment #5)
> ...long standing RFE bug 46448

If we accept this request, fine for me. Would make this ticket a duplicate.
Comment 7 Thomas Lendo 2020-06-09 19:37:58 UTC
(In reply to Heiko Tietze from comment #6)
> (In reply to Eike Rathke from comment #5)
> > ...long standing RFE bug 46448
> If we accept this request, fine for me. Would make this ticket a duplicate.
Is the request for an "Insert as plain text" checkbox worth to hold this bug open?
Comment 8 Heiko Tietze 2020-06-14 12:02:16 UTC
Let's make it a duplicate then.

*** This bug has been marked as a duplicate of bug 46448 ***