Bug 132998 - macOS: can't change the shape of data points in "points and lines" chart
Summary: macOS: can't change the shape of data points in "points and lines" chart
Status: RESOLVED DUPLICATE of bug 131333
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.3.2 release
Hardware: All Mac OS X (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2020-05-13 09:34 UTC by Aleksejs
Modified: 2020-05-13 20:03 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aleksejs 2020-05-13 09:34:30 UTC
Description:
In LibreOffice Calc 6.4 (for Mac). If you create a line chart with "points and lines" you are getting square looking points by default. If you want to change to the points to round or triangle or any other, it is impossible to do.
It is possible in LibreOffice Calc 6.3.

Steps to Reproduce:
1. Add chart
2. Line Chart
3. "Pints and lines"
4. Change points from square looknig to round, by double clicking on them and then changing Icon.

Actual Results:
Nothing is changing

Expected Results:
Change from square to round looking points


Reproducible: Always


User Profile Reset: No



Additional Info:
no
Comment 1 Ming Hua 2020-05-13 10:06:52 UTC
Can't reproduce with 7.0.0 alpha1 on Windows 10.  I can click on the data points, then choose "Format Data Series..." from the context menu, and change the shape of the points in that dialog.

Maybe a macOS only issue?
Comment 2 Aleksejs 2020-05-13 10:27:00 UTC
You conducted exactly the right steps.
As I mentioned in my report, that is occurring in MacOS.
But I am not sure that is MacOS issue, as you can change the shape in LO 6.3 for Mac, but not in LO 6.4 and not in LO 7.0 for Mac.
Comment 3 Alex Thurgood 2020-05-13 16:43:51 UTC
Confirming with 

Version : 6.4.3.5
Build ID : 4db9852e73d9e9d662fc8a2783bace79addf1805
Threads CPU : 8; OS : Mac OS X 10.15.4; UI Render : par défaut; VCL: osx; 
Locale : fr-FR (fr_FR.UTF-8); Langue IHM : fr-FR
Calc: threaded
Comment 4 Alex Thurgood 2020-05-13 16:45:13 UTC
==> regression, as this worked previously.
Comment 5 Alex Thurgood 2020-05-13 16:48:32 UTC
The change shows up in the key of the chart, but not in the chart itself.
Comment 6 Alex Thurgood 2020-05-13 16:52:31 UTC
This appears to work correctly in 

Version: 5.4.7.2
Build ID: c838ef25c16710f8838b1faec480ebba495259d0
Threads CPU : 8; OS : Mac OS X 10.15.4; UI Render : par défaut; 
Locale : fr-FR (fr_FR.UTF-8); Calc: grou
Comment 7 Alex Thurgood 2020-05-13 16:54:52 UTC
Also works in 
Version: 6.0.6.2
Build ID: 0c292870b25a325b5ed35f6b45599d2ea4458e77
Threads CPU : 8; OS : Mac OS X 10.15.4; UI Render : par défaut; 
Locale : fr-FR (fr_FR.UTF-8); Calc: grou
Comment 8 Alex Thurgood 2020-05-13 16:58:09 UTC
Also appears to work correctly in 

Version: 6.2.4.2
Build ID: 2412653d852ce75f65fbfa83fb7e7b669a126d64
Threads CPU : 8; OS : Mac OS X 10.15.4; UI Render : par défaut; VCL: osx; 
Locale : fr-FR (fr_FR.UTF-8); Langue IHM : fr-FR
Calc: threaded
Comment 9 Alex Thurgood 2020-05-13 16:59:50 UTC
Works correctly in 
Version: 6.2.8.2
Build ID: f82ddfca21ebc1e222a662a32b25c0c9d20169ee
Threads CPU : 8; OS : Mac OS X 10.15.4; UI Render : par défaut; VCL: osx; 
Locale : fr-FR (fr_FR.UTF-8); Langue IHM : fr-FR
Calc: threaded
Comment 10 Alex Thurgood 2020-05-13 17:01:30 UTC
Works correctly in 
Version: 6.3.4.2
Build ID: 60da17e045e08f1793c57c00ba83cdfce946d0aa
Threads CPU : 8; OS : Mac OS X 10.15.4; UI Render : par défaut; VCL: osx; 
Locale : fr-FR (fr_FR.UTF-8); Langue IHM : fr-FR
Calc: threaded
Comment 11 Alex Thurgood 2020-05-13 17:03:25 UTC
Bug reproduced in

Version : 6.4.3.2
Build ID : 747b5d0ebf89f41c860ec2a39efd7cb15b54f2d8
Threads CPU : 8; OS : Mac OS X 10.15.4;
Comment 12 eisa01 2020-05-13 20:03:12 UTC
This looks like a duplicate of bug 131333

*** This bug has been marked as a duplicate of bug 131333 ***