Download it now!
Bug 133012 - elementary: The gripper icon looks like a “More Options” menu
Summary: elementary: The gripper icon looks like a “More Options” menu
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.4.3.2 release
Hardware: All All
: low minor
Assignee: Rizal Muttaqin
URL:
Whiteboard: target:7.0.0 target:6.4.5
Keywords:
Depends on:
Blocks: Icon-Theme-Elementary
  Show dependency treegraph
 
Reported: 2020-05-13 19:06 UTC by Adolfo Jayme
Modified: 2020-05-14 09:43 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Toolbar grip (1.07 KB, image/png)
2020-05-13 20:45 UTC, V Stuart Foote
Details
Sidebar grip (1.08 KB, image/png)
2020-05-13 20:45 UTC, V Stuart Foote
Details
Screenshot of sidebar grip thingy (2.22 KB, image/png)
2020-05-14 01:53 UTC, Adolfo Jayme
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adolfo Jayme 2020-05-13 19:06:31 UTC
The gripper icon in the elementary theme looks like a rounded button that you can click to display a menu, not like a draggable element to move a toolbar or sidebar deck. Please remove the rounded disc from the icon and leave only the vertical row of dots, like in the other icon themes.
Comment 1 V Stuart Foote 2020-05-13 20:45:28 UTC
Created attachment 160788 [details]
Toolbar grip

@Adolofo, where? With Elementary icon theme set enabled on Windows build of master/7.0.0 the Toolbars show just the 5 dots, Sidebar Deck Titlebar shows a 4 dot icon--where is the "rounded button" effect?
Comment 2 V Stuart Foote 2020-05-13 20:45:54 UTC
Created attachment 160789 [details]
Sidebar grip
Comment 3 Rizal Muttaqin 2020-05-13 22:49:52 UTC
(In reply to V Stuart Foote from comment #2)
> Created attachment 160789 [details]
> Sidebar grip

Guess you have not restart the whole app after changing the icon theme to elementary.


I confirmed this issue and yes I'm agree that the icon violates the UI standard. Previously, I just want to synchronize with the chevron icon (more items actions) .
Comment 4 Adolfo Jayme 2020-05-14 01:53:05 UTC
Created attachment 160794 [details]
Screenshot of sidebar grip thingy

Looks like this to me using…

Version: 7.0.0.0.alpha1
Build ID: 6a03b2a54143a9bc0c6d4c7f1...
Subprocs. CPU: 2; SO: Linux 5.4; Repres. IU: predet.; VCL: gtk3; 
Locale: es-MX (es_MX.UTF-8); UI: es-ES
Calc: threaded
Comment 5 Commit Notification 2020-05-14 08:10:37 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/879d293d2f7734d7de51e57532743a24a3dd322d

elementary:tdf#133012 gripper icons looks like a more option button

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2020-05-14 09:19:56 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/f8e6e545a6cc205fe7450f00acaff9d72e2d617c

elementary:tdf#133012 gripper icons looks like a more option button

It will be available in 6.4.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.