Bug 133044 - LO Base does not import pictures when using an Apple Mac
Summary: LO Base does not import pictures when using an Apple Mac
Status: RESOLVED DUPLICATE of bug 128233
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.3.6.2 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-14 20:20 UTC by Wendy
Modified: 2020-05-15 07:15 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wendy 2020-05-14 20:20:40 UTC
Description:
I am unable to link or import images into Base. When I click the "insert image from" dialog box the pc waits (spinning disc instead of mouse) for several seconds and no image is added. 

I can add images using window pc, using the same technique.

Using LO version 6.3.6.2 on both windows and Mac. Mac pc using Catalina 10.15.4

Steps to Reproduce:
I followed the tutorial examples for embedding and linking a picture

https://thefrugalcomputerguy.com/grouppg.php?ser=15&grp=7#Lnk_Dscrpt_



Actual Results:
After about 10 seconds of the Mac mouse cursor changing to a spinning disc, the mouse cursor returns and Libre office continues to work, but no image in a table.

Expected Results:
expected an image to be inserted


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.3.6.2
Build ID: 2196df99b074d8a661f4036fca8fa0cbfa33a497
CPU threads: 4; OS: Mac OS X 10.15.4; UI render: default; VCL: osx; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Alex Thurgood 2020-05-15 07:15:12 UTC
This is probably because the app is not correctly notarized and therefore the OS blocks the app from accessing outside directories, see bug 126409

In the meanwhile, marking as DUP of bug 128233

A possible workaround is given at comment 16 of bug 128233, by enabling Full Disk Access to the LibreOffice.app bundle (under System Preferences > Security)

*** This bug has been marked as a duplicate of bug 128233 ***