Bug 133151 - First time user experience: Inform and ask about over UI types (tabbed UI etc.)
Summary: First time user experience: Inform and ask about over UI types (tabbed UI etc.)
Status: RESOLVED DUPLICATE of bug 117463
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.4.3.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2020-05-18 16:33 UTC by kdedk
Modified: 2020-06-08 11:38 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kdedk 2020-05-18 16:33:30 UTC
Description:
It seems like a lot of users don't know that the tabbed layout exist although they would find it much better and more intuitive than the old "Office 2003" layout. It would be great if each user would be informed and asked at least once which layout it wants to use. For first time installations, this could be asked directly after the installation of LibreOffice at the first run. For users who already have installed it, it could be asked through the GUI once if it is not asked before. Asking while installing/updating LibreOffice in the installer is not a good idea because - for example, on Linux - in some OS's there are no custom installation routines like on Windows.

Steps to Reproduce:
Use LibreOffice.

Actual Results:
You get the standard "Office 2003" layout and - in the program itself - no information about other layouts.

Expected Results:
You are informed and asked (at least one time) about the different UI types.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.4.3.2
Build-ID: 6.4.3-3
CPU-Threads: 4; BS: Linux 5.6; UI-Render: Standard; VCL: gtk3; 
Gebietsschema: de-DE (de_DE.utf8); UI-Sprache: de-DE
Calc: threaded
Comment 1 Timur 2020-05-18 19:30:28 UTC
I support and ask UX.
Comment 2 Heiko Tietze 2020-05-19 04:04:28 UTC
It's a duplicate and was rejected in the past. We deliberately dropped the dialog to gather user information and shouldn't introduce another query.

However, a tip of the day with a nice illustration could attract some users.

*** This bug has been marked as a duplicate of bug 117463 ***
Comment 3 V Stuart Foote 2020-05-19 15:18:55 UTC

*** This bug has been marked as a duplicate of bug 117463 ***
Comment 4 Pedro 2020-05-19 15:19:51 UTC
I seriously disagree that this is closed.
The last time this was discussed was two years ago which is plenty of time.
Furthermore, most of the issues raised on that bug are already surpassed. 
Those issues were:
1 - The alternative UIs were still experimental so that discussion was premature by Stuart V Foote.
2 - Need to implement the missing features which are currently only in the classic toolbar by Samuel Mehrbrodt.

Those two issues don't apply anymore so this discussion should be had now.
I agree with kdek and Timur that a dialog should be done to point the user to select the preferred UI. 
IMO, that would be much more useful than having a "tip of the day" dialog. Or simply hardcode the first "tip of the day" dialog after an installation to make the user select a UI, or at least point the user to where to select the UI.
Comment 5 V Stuart Foote 2020-05-19 15:41:25 UTC
No, just no... otherwise  "Clippy" is Back! 

Duplicate and => WF
Comment 6 V Stuart Foote 2020-05-19 15:52:50 UTC

*** This bug has been marked as a duplicate of bug 117463 ***