Bug 133166 - Remove Skia options until they work on macOS
Summary: Remove Skia options until they work on macOS
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha1+
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.0.0
Keywords:
Depends on:
Blocks: Skia
  Show dependency treegraph
 
Reported: 2020-05-19 11:15 UTC by Alex Thurgood
Modified: 2020-08-06 07:24 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Thurgood 2020-05-19 11:15:02 UTC
Description:
Start LO 7 alpha 1.
Under Preferences > LO Dev > View 

there are a number of Skia-related option tickboxes which do nothing as yet, because Skia is not yet supported on macOS. However, the user can still see and tick the boxes, thinking that they might actually do something.

These boxes should be removed until such time as Skia is implemented for macOS. 

Steps to Reproduce:
See above description

Actual Results:
Skia option boxes can be ticked, misleading the user into thinking that they actually do something, whereas they don't.

Expected Results:
Skia boxes shouldn't be shown until Skia is actually supported on macOS.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 7.0.0.0.alpha1
Build ID: 6a03b2a54143a9bc0c6d4c7f1...
CPU threads: 8; OS: Mac OS X 10.15.4; UI render: default; VCL: osx; 
Locale: fr-FR (fr_FR.UTF-8); UI: en-US
Calc: threaded
Comment 1 Commit Notification 2020-05-23 12:04:50 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/c42550f520e896abc59d91d588eb3ae9f0e0609d

show Skia UI controls only on Windows for now (tdf#133166)

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.