Download it now!
Bug 133169 - EDITING: Paste as RTF: most of content is missing
Summary: EDITING: Paste as RTF: most of content is missing
Status: VERIFIED DUPLICATE of bug 132596
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.0.beta1+
Hardware: All All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:7.1.0
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2020-05-19 12:32 UTC by Xisco Faulí
Modified: 2020-06-09 16:29 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
document after paste (17.39 KB, application/vnd.oasis.opendocument.text)
2020-05-19 12:32 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-05-19 12:32:02 UTC
Created attachment 161003 [details]
document after paste

Steps to Reproduce:
- Open attachment 94362 [details] from bug 75208
- CTRL+A
- CTRL+C
- CTRL+N
- CTRL+SHIFT+V (paste as RTF)

-> Only 1 page is paste

Reproduced in

Version: 7.0.0.0.alpha1+
Build ID: 8209c2569f5726f9ed29f75d30efdccb94f98fe5
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 1 Xisco Faulí 2020-05-19 12:38:49 UTC
it was fine up to https://cgit.freedesktop.org/libreoffice/core/commit/?id=4dc1615c80e8e66d339dc86fa95bbc76e884d988. Then it started to crash copying the content ( bug 129805 ).
The crash was fixed in 
https://git.libreoffice.org/core/commit/cf226535f9903a048b1c105b180ae3a50a776e68
and from this moment on, this issue is reproducible

Adding Cc: to Michael Stahl
Comment 2 Xisco Faulí 2020-05-29 14:42:13 UTC
sw/qa/uitest/writer_tests/data/tdf131963.docx is affected by this issue and test added in https://cgit.freedesktop.org/libreoffice/core/commit/?id=d5971a5b1ec19b3c8ff39b32fc9bc57f1083b8ab can be extended to test this issue once it's fixed too.
Comment 3 Michael Stahl (CIB) 2020-06-08 12:28:35 UTC
apparently fixed by my fix for bug 132596

*** This bug has been marked as a duplicate of bug 132596 ***
Comment 4 Xisco Faulí 2020-06-09 08:06:49 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: e0f058bcd5e185b89e4b7c680a7901bc7eb2a790
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Michael, thanks for fixing this issue!!
Comment 5 Commit Notification 2020-06-09 16:29:57 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/8a88f898313a01a8408a2e66b62b66899bb9faac

tdf#133169: sw: Add UItest

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.