Download it now!
Bug 133181 - The character style preview in the sidebar doesn't show highlighting
Summary: The character style preview in the sidebar doesn't show highlighting
Status: RESOLVED DUPLICATE of bug 93756
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.5.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-19 21:18 UTC by Telesto
Modified: 2020-08-28 07:35 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-05-19 21:18:47 UTC
Description:
The character style preview in the sidebar doesn't show highlighting

Steps to Reproduce:
1. open Writer
2. Go styles sidebar
3. Go to character styles
4. Right Click a style - Modify
6. Highlighting tab -> Pick a color & Press OK

Actual Results:
No highlighting color in preview

Expected Results:
Should be (same as paragraph preview)


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.0.0.alpha1+ (x64)
Build ID: f9790da286f2d2fa47f1748f8cfa6172c6622ca3
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
Locale: de-CH (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-05-19 21:22:05 UTC
Is this by design.. or
Comment 2 Heiko Tietze 2020-05-20 13:06:01 UTC
We discussed the topic 2018-APR-11

* Corner cases of style preview
+ https://bugs.documentfoundation.org/show_bug.cgi?id=115507
+ Have a full WYSYWIG preview or minimum contrast
+ Solution for the toolbar in https://bugs.documentfoundation.org/show_bug.cgi?id=58161
+ we we show font/background color and font name, size and do not provide a full preview, so rather WFM (Stuart)
+ compromise to ignore font/background color when item is selected?
or on hover like at the dropdown (Gökhan)
+ wouldn't solve the other use case if a user makes a font size very small and zooms in at the document
=> reject ticket as WFM/WF

Check also the referenced tickets, many reports are about white on white.

Point is, what attributes we show WYSIWYG is a bottomless pit. Other requests are about alignment, consider also the various spacing options, etc. And ultimately there is a checkbox to have pure text.
Comment 3 Telesto 2020-05-20 13:47:27 UTC
Thanks for looking up the topic.. but searching for yes/no answer.

The paragraph style preview shows highlighting in the preview (sidebar); however currently somewhat broken bug 133180. The character style preview doesn't show highlighting at all.. and it maybe never worked.. tested 5.2.5 (not sure when the preview has been introduced..). I expect the character style preview to work the same as paragraph style preview
Comment 4 Heiko Tietze 2020-05-20 14:09:24 UTC
(In reply to Telesto from comment #3)
> The paragraph style preview shows highlighting in the preview (sidebar)...

True, wasn't there in 6.3. Should investigate who implemented it.
Comment 5 Telesto 2020-05-20 17:39:56 UTC
Styles & Formatting deck of the Sidebar now displays a preview of the available styles. core commit ca95307638207db5d662059aa61594151a13e927
(Tomaž Vajngerl, Collabora)
Comment 6 Heiko Tietze 2020-05-22 13:23:59 UTC
(In reply to Telesto from comment #5)
> core commit ca95307638207db5d662059aa61594151a13e927

Not sure that this is related
Comment 7 Telesto 2020-08-28 07:35:02 UTC

*** This bug has been marked as a duplicate of bug 93756 ***