Bug 133202 - FORMATTING, EDITING: LibreCalc strikes through the whole comment and removes hyphens in comments
Summary: FORMATTING, EDITING: LibreCalc strikes through the whole comment and removes ...
Status: RESOLVED DUPLICATE of bug 133023
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-20 18:15 UTC by Am Jam
Modified: 2020-05-20 20:45 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Am Jam 2020-05-20 18:15:30 UTC
Description:
In LibreCalc, there is a bug in the markdown used within comments. Any hyphenated word will remove all hyphens and will stirke-through the whole comment. 

Steps to Reproduce:
1. Right click on any cell
2. Click "Insert Comment"
3. Write any sentence with a hyphen, e.g., "-15: Temperature needed for cool-down"

Actual Results:
Notice how the first hyphen before "15" is removed, the hyphen between "cool" and "down" is removed, and the whole line is marked as strike-through.

Expected Results:
A comment that just says "-15: Temperature needed for cool-down" with no bold, italics, or strike-through in the comment whatsoever. 


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
N/A.
Comment 1 Telesto 2020-05-20 20:45:37 UTC
The call it a feature ;-)..
Menu Tools -> Autocorrect -> Options ->  and uncheck Automatic *bold* ...

But it's in discussion to change the default to off

*** This bug has been marked as a duplicate of bug 133023 ***