Download it now!
Bug 133215 - Skia: GIF image not visible, exported correctly
Summary: Skia: GIF image not visible, exported correctly
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.0.0
Keywords:
: 133246 133254 133275 (view as bug list)
Depends on:
Blocks: Skia
  Show dependency treegraph
 
Reported: 2020-05-21 08:41 UTC by Timur
Modified: 2020-05-29 20:02 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
ODT print with Skia (294.66 KB, application/pdf)
2020-05-21 08:41 UTC, Timur
Details
ODT print no Skia (258.42 KB, application/pdf)
2020-05-21 08:42 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2020-05-21 08:41:27 UTC
Created attachment 161062 [details]
ODT print with Skia

Open ODT attachment 152744 [details] from bug 126368 and see no GIF image on 1st page, only if Skia enabled. 
It's exported to PDF correctly and printed black (seen with virtual printer).
Repro in Windows with 7.0+. Present is Skia off and present in 6.4 with OpenGL.
I have no Skia on Linux to test, without it is fine.
Comment 1 Timur 2020-05-21 08:42:14 UTC
Created attachment 161063 [details]
ODT print no Skia
Comment 2 Telesto 2020-05-21 11:52:18 UTC
Seeing no image with (and printing black)
Version: 7.0.0.0.alpha1+ (x64)
Build ID: 442c7b95e2ee94b66a9854d0cb22f8ecb76532c6
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 3 Commit Notification 2020-05-21 14:34:10 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d14ed4c3365605060a4b8a72946dd27910cecdc4

fix image caching in Skia (tdf#133215)

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Luboš Luňák 2020-05-21 21:31:54 UTC
*** Bug 133246 has been marked as a duplicate of this bug. ***
Comment 5 Luboš Luňák 2020-05-22 12:34:15 UTC
*** Bug 133254 has been marked as a duplicate of this bug. ***
Comment 6 Timur 2020-05-22 13:44:56 UTC Comment hidden (obsolete)
Comment 7 Luboš Luňák 2020-05-22 17:21:45 UTC
*** Bug 133275 has been marked as a duplicate of this bug. ***
Comment 8 Luboš Luňák 2020-05-22 17:34:58 UTC
(In reply to Timur from comment #6)
> ODT attachment 152744 [details] is now seen but print is worse (than I
> reported in bug 133216), completely empty with and without Skia. 
> I think that also affected is attachment 110833 [details] from bug 87304.

I cannot reproduce with current master.
Comment 9 Timur 2020-05-23 15:31:20 UTC
It was tested in Windows with build from 22.05.
Comment 10 Timur 2020-05-25 09:52:31 UTC
Buovjaga, you made bibisects in bug 133216 and it's related. Is this wrongly reopened, what are the culprits for empty prints?
Comment 11 Buovjaga 2020-05-25 14:00:09 UTC
(In reply to Timur from comment #10)
> Buovjaga, you made bibisects in bug 133216 and it's related. Is this wrongly
> reopened, what are the culprits for empty prints?

Empty print culprints are mentioned in bug 133216.

I could repro bug 133215 with a build from a few days ago, but now when I updated to 25.5. build, I can see the GIF on 1st page again