Download it now!
Bug 133227 - UI Add Show Leader Lines checkbox
Summary: UI Add Show Leader Lines checkbox
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Balázs Varga
URL:
Whiteboard: target:7.1.0
Keywords:
Depends on: 134563 134571
Blocks: Chart-Enhancements
  Show dependency treegraph
 
Reported: 2020-05-21 13:15 UTC by NISZ LibreOffice Team
Modified: 2020-09-18 18:27 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file from Excel with leader lines (13.12 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2020-05-21 13:15 UTC, NISZ LibreOffice Team
Details
The example file saved to ODS (15.97 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-05-21 13:16 UTC, NISZ LibreOffice Team
Details
Screenshot of the original and exported document side by side in Excel and Calc (111.39 KB, image/png)
2020-05-21 13:16 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2020-05-21 13:15:47 UTC
Created attachment 161078 [details]
Example file from Excel with leader lines

Since bug #90749 was fixed, it is possible to use leader lines with chart labels: we can import them from OOXML (without all the fancy line formatting...), draw them on the chart and save their presence to ODF.
The Data Labels dialog however lacks a checkbox to turn them on/off.

Steps to reproduce:
    1. Open attached files to see a simple line chart with leader lines
    2. Open the Data Labels dialog

Actual results:
No Show Leader Lines checkbox.

Expected results:
Show Leader Lines checkbox present to turn leader lines on/off.

LibreOffice details:
Version: 7.0.0.0.alpha1+ (x64)
Build ID: 442c7b95e2ee94b66a9854d0cb22f8ecb76532c6
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL
Comment 1 NISZ LibreOffice Team 2020-05-21 13:16:09 UTC
Created attachment 161079 [details]
The example file saved to ODS
Comment 2 NISZ LibreOffice Team 2020-05-21 13:16:26 UTC
Created attachment 161080 [details]
Screenshot of the original and exported document side by side in Excel and Calc
Comment 3 BogdanB 2020-05-26 15:31:49 UTC
Version: 7.0.0.0.alpha1+
Build ID: 49fc4913ba7fc4a0be2e32407205edd8f31b3172
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-05-22_14:04:10
Calc: threaded
Comment 4 Commit Notification 2020-09-15 07:58:18 UTC
Balazs Varga committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/28b53da4c49b2dc8550f28b07183fb7c60e1c298

tdf#133227 chart UI: option to hide leader lines

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 BogdanB 2020-09-18 18:27:04 UTC
Verified in 
Version: 7.1.0.0.alpha0+
Build ID: d57b14e3394b081adf0888ed8dcb7b86d66c246c
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-US (ro_RO.UTF-8); UI: en-US
Calc: threaded


We have that new option in Format Data Labels - Data Labels - Leader Lines - checkbox "Connect displaced data labels to data points"