Download it now!
Bug 133236 - Adding a row or column to a "Default Style" table changes the formatting of existing cells
Summary: Adding a row or column to a "Default Style" table changes the formatting of e...
Status: RESOLVED DUPLICATE of bug 121023
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Writer-Tables-Style
  Show dependency treegraph
 
Reported: 2020-05-21 16:12 UTC by William Friedman
Modified: 2020-05-25 09:07 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Bibisect log (2.91 KB, text/plain)
2020-05-23 20:23 UTC, Telesto
Details
Example file (8.91 KB, application/vnd.oasis.opendocument.text)
2020-05-23 20:24 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description William Friedman 2020-05-21 16:12:46 UTC
Description:
The "default style" table is in Liberation Serif 12pt. The "Table Contents" style is Times New Roman 12pt. I select the table, change the font/apply the Table Contents style, and everything changes correctly to Times New Roman 12pt. I then add a row or column, either by tabbing or by doing "add row" or "add column"; the existing text in the table reverts to Liberation Serif 12pt.

Steps to Reproduce:
1. Create a table using default style.
2. Enter some text wherever.
3. Apply the Table Contents style or change the font directly to that text.
4. Add a row or column.

Actual Results:
Entire table changes back to Liberation Serif 12pt.

Expected Results:
Existing text would remain in the selected style/font.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.4.3.2 (x64)
Build ID: 747b5d0ebf89f41c860ec2a39efd7cb15b54f2d8
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: default; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 1 Telesto 2020-05-22 14:04:13 UTC
Found in
Version: 7.0.0.0.alpha1+ (x64)
Build ID: 442c7b95e2ee94b66a9854d0cb22f8ecb76532c6
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL

but not in
Version: 6.0.6.0.0+
Build ID: c30963b8b4bbbe42a24b97aafa161eff9d7ccdd4
CPU threads: 4; OS: Windows 6.3; UI render: GL; 
Locale: nl-NL (nl_NL); Calc: CL
Comment 2 Telesto 2020-05-23 20:23:59 UTC
Created attachment 161203 [details]
Bibisect log

Bisected to:
author	Jakub Trzebiatowski <ubap.dev@gmail.com>	2016-06-21 00:31:01 +0200
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2016-07-07 09:02:15 +0000
commit	40fba0f4418084d50cc5c388cb0b6e1abe395d61 (patch)
tree	4b1e97aa7755c80d9a8749fb94dc3fe26a2f35fb
parent	046244bcfe1c5c1cd2325fe74b933c05e43cf190 (diff)
GSoC Writer Table Styles Import
This patch is implementing import of table styles (table-template).

Modified shared code: Added "background" to the cell styles export.

To make cell export properties map accessible by both export and import code,
moved from xmloff/source/table/XMLTableExport.cxx to xmloff/txtprmap.hxx.

To avoid export of default valued properties implemented XPropertyState for
SwXTextCellStyle

https://cgit.freedesktop.org/libreoffice/core/commit/?id=40fba0f4418084d50cc5c388cb0b6e1abe395d61
Comment 3 Telesto 2020-05-23 20:24:23 UTC
Created attachment 161204 [details]
Example file
Comment 4 Telesto 2020-05-23 20:25:28 UTC
Adding CC to Jakub Trzebiatowski
Comment 5 Telesto 2020-05-23 20:26:13 UTC
@Heiko
Is Jakub Trzebiatowski still around.. Or is this something for Jim?
Comment 6 Telesto 2020-05-24 12:17:41 UTC
Adding (additionally) CC to Miklos Vajna (as probably mentor of Jakub Trzebiatowski)
Comment 7 Heiko Tietze 2020-05-25 08:30:35 UTC
Since creation of table styles is limited (bug 49437), we had to include all properties. The issue has been reported before in bug 121023.

*** This bug has been marked as a duplicate of bug 121023 ***
Comment 8 Telesto 2020-05-25 09:06:16 UTC
(In reply to Heiko Tietze from comment #7)
> Since creation of table styles is limited (bug 49437), we had to include all
> properties. The issue has been reported before in bug 121023.
> 
> *** This bug has been marked as a duplicate of bug 121023 ***

This sound weird to me.. it did work before.. bug 121023 is indeed the same.. but bibisect is wrong..
Comment 9 Telesto 2020-05-25 09:07:22 UTC

*** This bug has been marked as a duplicate of bug 121023 ***