Download it now!
Bug 133275 - Image disappears when document zoom level is reduced
Summary: Image disappears when document zoom level is reduced
Status: RESOLVED DUPLICATE of bug 133215
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Skia
  Show dependency treegraph
 
Reported: 2020-05-22 13:38 UTC by NISZ LibreOffice Team
Modified: 2020-08-16 19:34 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file from Word (56.70 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-05-22 13:38 UTC, NISZ LibreOffice Team
Details
The example file with reduced zoom levels on Skia rendering (132.17 KB, image/png)
2020-05-22 13:38 UTC, NISZ LibreOffice Team
Details
The example file with reduced zoom levels on non-Skia Win rendering (132.83 KB, image/png)
2020-05-22 13:39 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2020-05-22 13:38:13 UTC
Created attachment 161143 [details]
Example file from Word

Attached document was uploaded to bug #77794

When this file is opened in Writer, the image is rendered correctly.
Reducing the document zoom level (it is 98% by default) however makes it disappear from rendering, but only with Skia. Increasing zoom level has no similar effect.

Steps to reproduce:
    1. Open attached file and try to set zoom levels under 98%.

Actual results:
Magenta image disappears. Increasing the zoom level above 98% makes it appear again.

Expected results:
Image always stays visible.

LibreOffice details:
Version: 7.0.0.0.alpha1+ (x64)
Build ID: 442c7b95e2ee94b66a9854d0cb22f8ecb76532c6
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win; 
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL
Comment 1 NISZ LibreOffice Team 2020-05-22 13:38:46 UTC
Created attachment 161144 [details]
The example file with reduced zoom levels on Skia rendering
Comment 2 NISZ LibreOffice Team 2020-05-22 13:39:24 UTC
Created attachment 161145 [details]
The example file with reduced zoom levels on non-Skia Win rendering
Comment 3 Aron Budea 2020-05-22 14:03:59 UTC
Possibly a duplicate of bug 133215, can you check with a more recent build that includes the following commit?
https://git.libreoffice.org/core/commit/d14ed4c3365605060a4b8a72946dd27910cecdc4
Comment 4 Luboš Luňák 2020-05-22 17:21:45 UTC

*** This bug has been marked as a duplicate of bug 133215 ***
Comment 5 NISZ LibreOffice Team 2020-05-25 12:30:09 UTC
Works with todays nightly, thanks!

Version: 7.0.0.0.alpha1+ (x64)
Build ID: 21875558f6c478f07d68ff39e025d7ffd451674f
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL
Comment 6 Commit Notification 2020-08-16 13:21:20 UTC Comment hidden (off-topic)