Bug 133319 - Paint fill tool has no effect
Summary: Paint fill tool has no effect
Status: RESOLVED DUPLICATE of bug 90853
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.4.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2020-05-23 17:02 UTC by Menoo
Modified: 2020-05-23 19:27 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (8.12 KB, application/vnd.oasis.opendocument.graphics)
2020-05-23 18:16 UTC, Telesto
Details
fill color button (104.94 KB, image/jpeg)
2020-05-23 18:44 UTC, Menoo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Menoo 2020-05-23 17:02:54 UTC
Description:
Pretend you know nothing about LibreOffice and you came from using MS PowerPoint...

If you click on the fill toolbar icon to change the color of an object, it does nothing.

Steps to Reproduce:
1.  Draw a polygon that is not already filled.
2.  Select polygon if not already selected.
3.  Click on the polygon fill tool and select a fill color.

Actual Results:
Does nothing

Expected Results:
Expect it to fill with selected color.


Reproducible: Always


User Profile Reset: No



Additional Info:
I know now, after much time wasted, that you can right click on an object and select Area, which provides fill options.  That's great but if an object's fill property is set to "none" by default, selecting a color on the toolbar does nothing, which is non-intuitive.  If the polygon has no pre-existing fill, and a color is selected from the toolbar, the fill property should automatically convert to "color" with the selected fill color.  Also, the fill icon should have a means of selecting the fill type:  None, Color, Gradient, Bitmap, Pattern, Hatch.
Comment 1 Telesto 2020-05-23 18:16:00 UTC
Created attachment 161197 [details]
Example file
Comment 2 Telesto 2020-05-23 18:17:48 UTC
Confirm
Version: 7.0.0.0.alpha1+ (x64)
Build ID: 9a7c5d38a7a43c75c0f3d2f0c725196e916d0260
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win; 
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL

There is some more discussion somewhat related to this: bug 132880
Comment 3 Menoo 2020-05-23 18:44:09 UTC
Created attachment 161200 [details]
fill color button

Here's an example....
I drew an unfilled polygon.
I clicked on the paint icon.
I chose a color.
The polygon does not fill with the selected color because the fill attribute is still set to 'none'.
Comment 4 Menoo 2020-05-23 18:44:52 UTC
(In reply to Telesto from comment #2)
> Confirm
> Version: 7.0.0.0.alpha1+ (x64)
> Build ID: 9a7c5d38a7a43c75c0f3d2f0c725196e916d0260
> CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL:
> win; 
> Locale: nl-NL (nl_NL); UI: en-US
> Calc: CL
> 
> There is some more discussion somewhat related to this: bug 132880



Version: 6.4.3.2 (x64)
Build ID: 747b5d0ebf89f41c860ec2a39efd7cb15b54f2d8
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: default; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 5 Maxim Monastirsky 2020-05-23 19:27:50 UTC

*** This bug has been marked as a duplicate of bug 90853 ***