Bug 133420 - Release Notes for removal of trend lines for ODF 1.2 missing
Summary: Release Notes for removal of trend lines for ODF 1.2 missing
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Michael Stahl (allotropia)
URL: https://wiki.documentfoundation.org/R...
Whiteboard: odf
Keywords:
Depends on:
Blocks: Chart ODF-export-invalid
  Show dependency treegraph
 
Reported: 2020-05-26 18:34 UTC by Regina Henschel
Modified: 2020-06-03 16:58 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2020-05-26 18:34:48 UTC
This is a follow up to bug 130133.
Now the for ODF 1.2 invalid trend lines of type 'polynomial' and 'moving average' are no longer written in case of 'ODF 1.2 extended'.
But the note in the release notes is missing.
Comment 1 Regina Henschel 2020-05-26 18:55:42 UTC
Moving average properties are written in loext namespace in case of save to "ODF 1.2 extended" in
Version: 7.0.0.0.alpha1+ (x64)
Build ID: 0e5e935deb0527c64865cfcc53a0421e56b74b6f
CPU threads: 8; OS: Windows 10.0 Build 18362; UI render: Skia/Raster; VCL: win
Locale: de-DE (en_US); UI: en-US
Calc: CL

That is correct in principle. But neither LO 6.4.3 nor LO 7.0 can read it.
Comment 2 Regina Henschel 2020-05-27 07:34:41 UTC
@Michael: Please comment, what to do about these useless loext:regression-* attributes in case of saving in "ODF 1.2 extended".
Comment 3 Michael Stahl (allotropia) 2020-05-27 08:01:46 UTC
for ODF 1.2 extended the loext attributes are written but the new attribute values for the type are not written, so the loext attributes are indeed useless.

but avoiding the writing of the loext attributes got a bit more difficult now since this:

  For developers who want to add new ODF extensions, we would like to point out the behavioral change in commit
  f1dbaac9e4b68941d845a5f0ab7b204e12de14de "xmloff: ODF export: rework version checks in SvXMLExportPropertyMapper"
  (see commit message) that should simplify things a little bit.

... so given that ODF 1.2 extended versions aren't the default i'd like to leave this as it is for simplicity because the loext attributes don't hurt anyone.
Comment 5 Regina Henschel 2020-06-03 16:58:27 UTC
Visited https://wiki.documentfoundation.org/index.php?title=ReleaseNotes%2F7.0 on 2020-06-03 and see correct text in section "ODF 1.3".