Bug 133422 - Writer Forms Control Field Name overrides Tab Order
Summary: Writer Forms Control Field Name overrides Tab Order
Status: RESOLVED DUPLICATE of bug 133158
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.8.2 release
Hardware: All macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 133421 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-05-26 19:06 UTC by peterpqa
Modified: 2020-06-29 15:13 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Writer Forms Control Field Name overrides Tab Order (35.04 KB, application/vnd.oasis.opendocument.text)
2020-05-26 19:09 UTC, peterpqa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description peterpqa 2020-05-26 19:06:43 UTC
Description:
Please also see Bug 133158. You may want to address both tab-order issues together.

In LO v6.2.8.2 and earlier, Field Name overrides Tab Order, so I had to name every field as "Field". See the attached "Alpha Name" example. All fields are named "Field" except the highlighted ones - their names are typed into in each field.

From "Alfa", tabbing progresses properly through Row 1. But then, tabbing skips over tab-order 201 ("Bravo") to tab-order 202, then skips over tab-order 301 ("Charlie") to tab-order 302, etc.

With Bug 133158, I cannot confirm that this problem persisted in 6.3 or 6.4. Perhaps in Windows, where Bug 133158 does not manifest?

Steps to Reproduce:
See description

Actual Results:
See description

Expected Results:
Software should obey my tab-order numbers, not Field Name alphanumeric order


Reproducible: Always


User Profile Reset: No



Additional Info:
Software let Field Name alphanumeric order override Tab Order
Comment 1 peterpqa 2020-05-26 19:09:19 UTC
Created attachment 161308 [details]
Writer Forms Control Field Name overrides Tab Order

Writer Forms Control Field Name overrides Tab Order
Comment 2 m.a.riosv 2020-05-26 20:34:38 UTC
*** Bug 133421 has been marked as a duplicate of this bug. ***
Comment 3 Xisco Faulí 2020-06-29 15:13:30 UTC
Thanks for reporting this issue.
it seems like a duplicate of bug 133158 and it should be fixed in LibreOffice 6.4.5 due to be released this week

*** This bug has been marked as a duplicate of bug 133158 ***