Download it now!
Bug 133467 - EDITING Image is not pasted into ODT when copied from MS Word DOCX
Summary: EDITING Image is not pasted into ODT when copied from MS Word DOCX
Status: RESOLVED DUPLICATE of bug 99507
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-28 08:01 UTC by thatho
Modified: 2020-06-09 12:27 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description thatho 2020-05-28 08:01:25 UTC
Description:
EDITING Image is not pasted when copied from MS Word. Clipboard contains the image and can be pasted elsewhere (image app, e.g. IrfanView)

Steps to Reproduce:
1. Paste any image into Writer, or open an ODT with image
2. Copy and paste any image from ODT (which you are sure is compatible with ODT) to MS Word document (MS WORD 2016 and DOCX were used at me)
3. Copy that image within MS Word document into the clipboard
4. Paste clipboard into the ODT document.

Actual Results:
The Writer window flashes (something has been triggered), but no image is pasted into the document.

Reveal the content of the clipboard by pasting into any other app (Calc, Draw, IrfanView).

Workaround: Use a pit-stop: Paste the image elsewhere and copy from there again into Writer.

Expected Results:
Image is pasted into the document.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.4.4.2 (x64)
Build ID: 3d775be2011f3886db32dfd395a6a6d1ca2630ff
CPU threads: 8; OS: Windows 10.0 Build 18362; UI render: default; VCL: win; 
Locale: cs-CZ (cs_CZ); UI-Language: en-US
Calc: threaded

Pasting into Draw or Calc (step 4.) works very well.
Comment 1 thatho 2020-05-28 09:30:31 UTC
I have just found out that the clipboard can be pasted as

4. Paste as... Ctrl+Shift+V
5. Choose Graphics Device Interface metadata (GDI)

So, that pasting option should be set as default somewhere?
Comment 2 Dieter 2020-06-01 15:52:56 UTC
I can't confirm it with

Version: 7.0.0.0.beta1 (x64)
Build ID: 94f789cbb33335b4a511c319542c7bdc31ff3b3c
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

To be certain the reported issue is not related to corruption in the user profile, could you please reset your Libreoffice profile (https://wiki.documentfoundation.org/UserProfile) and re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the issue is still present.
Comment 3 thatho 2020-06-02 10:04:41 UTC
Dear Dieter, thank you for the check in LO7 and the suggestion.

I removed and recreated my user profile for LO. The issue is still present.

Default paste does nothing visually. Paste as BMP does nothing visually. Paste as GDI pastes a screenshot instead of the copied object (that is the result is low resolution).
Comment 4 Timur 2020-06-09 12:11:56 UTC
Looks duplicate and resolved from 7.0. Please test yourself. 

thatho, since you have more reports so Lo contributor, please test always with master from https://dev-builds.libreoffice.org/daily/master/current.html. It's separate to your working LO. 

Dieter, if no repro with master you need to test with user's version. In this case it would be WFM but search reveals a duplicate.

*** This bug has been marked as a duplicate of bug 99507 ***
Comment 5 thatho 2020-06-09 12:27:59 UTC
Pasting from DOCX to ODT in LO 7.0.0.0 BETA1 works. Works as direct paste of the clipboard and works as BMP and GDI, too.

There is although some strange behaviour. The pasted content is not the original image from DOCX, but it is the image formatted to the image actual size. If the original image in DOCX has been reside, the copied results can never be larger without reducing quality. To copy the original image one shall reset the image dimensions in DOCX and copy that unmodified image.

Additionally, GDI style paste displays much lower resolution (kind of blurring).