Bug 133479 - FILESAVE: DOC/ODT: Numbering list formatting is lost after RT
Summary: FILESAVE: DOC/ODT: Numbering list formatting is lost after RT
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Vasily Melenchuk (CIB)
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-05-28 15:56 UTC by Xisco Faulí
Modified: 2020-06-12 20:05 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
sample file (17.44 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-05-28 15:56 UTC, Xisco Faulí
Details
Comparison MSO 2010 and LibreOffice 7.0 master (after RT) (337.78 KB, image/png)
2020-05-28 15:56 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-05-28 15:56:04 UTC
Created attachment 161378 [details]
sample file

Steps to reproduce:
1. Open attached document
2. Save it as .DOC file
3. open the recently created document

-> The numbering list on page 1 has changed from 1. to %1. and the indent has increased. See comparison image

Reproduced in

Version: 7.0.0.0.alpha1+
Build ID: 82894d85147840f1f587e9530b12f0058f2ef2c3
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded


[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2020-05-28 15:56:47 UTC
Created attachment 161379 [details]
Comparison MSO 2010 and LibreOffice 7.0 master (after RT)
Comment 2 Xisco Faulí 2020-05-28 15:57:55 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=7459b9ecb54a298f02d19089620149718f8d8d48

author	Vasily Melenchuk <vasily.melenchuk@cib.de>	2020-04-13 11:06:29 +0300
committer	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2020-04-27 22:36:12 +0200
commit 7459b9ecb54a298f02d19089620149718f8d8d48 (patch)
tree 8e26f751e26b4e4f7ca53d36d6c94603d096650c
parent 4ba179eb9208185406207522e39626327c7d74c3 (diff)
tdf#116883: sw: support for lists level format string

Bisected with: bibisect-linux64-6.5

Adding Cc: to Vasily Melenchuk
Comment 3 Xisco Faulí 2020-05-28 16:04:05 UTC
Also happening when saving to ODT
Comment 4 Vasily Melenchuk (CIB) 2020-06-12 11:16:24 UTC
Works for me right now.

No longer reproducible with master since https://gerrit.libreoffice.org/c/core/+/94383. Backports are done to 7.0 and 6.4.
Comment 5 Xisco Faulí 2020-06-12 20:05:30 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: ff508f6d8a3e58d29e9e7622006a7103fb0a2849
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Vasily, thanks for fixing this issue!!