Bug 133492 - Autofilter can't be easily/obviously re-run against additional data
Summary: Autofilter can't be easily/obviously re-run against additional data
Status: RESOLVED DUPLICATE of bug 130770
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: AutoFilter
  Show dependency treegraph
 
Reported: 2020-05-29 09:01 UTC by Tim B
Modified: 2021-04-11 19:25 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file to demonstrate the problem (11.12 KB, application/vnd.oasis.opendocument.spreadsheet)
2021-02-02 10:01 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tim B 2020-05-29 09:01:50 UTC
Description:
When using autofilter, in older versions, the filter could be reapplied/re-run across updated data by simply opening the filter dropdown on any already filtered column, and simply clicking OK without changing any options. This is something I was doing fairly regularly with larger lists where the freshly updated data could be filtered out to reduce wasted screen space.

At some stage, this has been changed so that nothing is updated unless at least one filter setting is changed. Presumably this is to optimise the filtering so it doesn't get re-run on unchanged data... However it also does not get re-run if the data set has been modified, and there is no obvious way to re-run the filter without making a change, clicking OK, re-opening the dropdown and changing it back.

Steps to Reproduce:
1.Create/load table of data that is suitable for filtering.
2.Enable autofilter
3.Filter out some data using the autofilter
4.Edit the document in such a way that the changes should be filtered out by the existing filter
5.Open autofilter dropdown dialog from top row and click OK

Actual Results:
Nothing happens.

Expected Results:
Filter should re-run and filter out any expected filtered rows.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.4.3.2
Build ID: 1:6.4.3-0ubuntu0.20.04.1
CPU threads: 12; OS: Linux 5.4; UI render: default; VCL: kf5; 
Locale: en-AU (en_AU.UTF-8); UI-Language: en-US
Calc: threaded

[Information automatically included from LibreOffice]
Locale: en-US
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes
Comment 1 V Stuart Foote 2020-05-29 14:15:42 UTC
Confirming.

Simple sheet with mix of data across columns with Header row assigned.

Apply autofilter to reduce shown rows.

Add additional rows of the same format to sheet (i.e. create on another sheet and cut/paste) with some that match the current autofilter some that do not.

Unable to 're-run' the filter against the newly added rows.
Comment 2 Sepp 2020-06-10 13:48:49 UTC
Confirmed

Selections must be changed and autofilter must be opened a second time.

After changed data pressing "OK" should be enough to filter changed data also.
Comment 3 Timur 2020-06-26 15:21:37 UTC
Stuart, reports says it worked, so that would be a regression? (I didn't test)
Comment 4 NISZ LibreOffice Team 2021-02-02 10:01:19 UTC
Created attachment 169386 [details]
Example file to demonstrate the problem

Example created by instructions in comment #1

- Copy the first 4 rows from Sheet2 to A11
- Drop down the filter on column B, press OK -> Filtering not updated
- Drop down the filter on column A, press OK -> Filtering updated, rows containing Wolf in column A are hidden.

This started to work like this in 6.3, in 6.2 and before pressing OK on Column B rerun the whole filtering as expected. 
Also, my Excel 2013 updates the whole filtering if column B is opened and closed with OK.
Comment 5 NISZ LibreOffice Team 2021-02-02 10:42:59 UTC
This seems to have started with:

https://git.libreoffice.org/core/+/4e7e3670c31329d60f5cc782abc4568c2aba33a7

author	Serge Krot <Serge.Krot@cib.de>	Tue Mar 05 17:03:31 2019 +0100
committer	Thorsten Behrens <Thorsten.Behrens@CIB.de>	Fri Apr 12 11:46:58 2019 +0200

tdf#117276 sc: autofilter was unexpected reset with OK pressed

Adding CC to: Serge Krot
Comment 6 Roland Kurmann 2021-04-04 20:39:59 UTC
This issue seems to be a duplicate of Bug 130770. 

Both issues are bibisected to the same commit 4e7e3670c31329d60f5cc782abc4568c2aba33a7.

Bug 130770 is fixed since 6.4.5. (I've fixed it.)

Can you verify and mark as duplicate?
Comment 7 Roland Kurmann 2021-04-11 19:25:37 UTC

*** This bug has been marked as a duplicate of bug 130770 ***