Bug 133542 - Pressing CTRL+W with a single document open closes LibreOffice
Summary: Pressing CTRL+W with a single document open closes LibreOffice
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.7.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2020-05-31 06:52 UTC by Telesto
Modified: 2020-06-04 13:01 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-05-31 06:52:52 UTC
Description:
Pressing CTRL+W with a single document open closes LibreOffice

Steps to Reproduce:
!. Lauch LibreOffice Start Center
2. Open a new document
3. Press CTRL+W

Actual Results:
LibreOffice closes

Expected Results:
1. Same behaviour as the grey cross.. back to start center
2. And if it was up to me; don't close start center with CTRL+W, if being the last window. We have CTRL+Q for quiting. Makes the behaviour more consistent across Windows/Mac/Linux


Reproducible: Always


User Profile Reset: No



Additional Info:
-
Comment 1 Regina Henschel 2020-05-31 11:29:33 UTC
That is the intended behavior for Ctrl+W. Ctrl+W is bound to command .uno:CloseWin with label "Close Window". It is located in menu Window in the menu bar.

You are looking for command .uno:CloseDoc. That is located in menu File and has label "Close". The command .uno:CloseDoc is bound to Ctrl+F4.

So for me a "Worksforme".
Comment 2 Telesto 2020-05-31 12:32:38 UTC
(In reply to Regina Henschel from comment #1)
> That is the intended behavior for Ctrl+W. Ctrl+W is bound to command
> .uno:CloseWin with label "Close Window". It is located in menu Window in the
> menu bar.
> 
> You are looking for command .uno:CloseDoc. That is located in menu File and
> has label "Close". The command .uno:CloseDoc is bound to Ctrl+F4.
> 
> So for me a "Worksforme".

Thanks for the clarification. Explains a lot

However no knowledge of the 'UX guidelines around CTRL+W. In Firefox/Vivaldi it always closes a tab never the application. Similar for Word. Closes the doc not the application

And on MacOS Cmd+W closes the application Window but LibreOffice keeps running in the Dock. 

ALT+F4 quite program. Never used CTRL+F4

So still interested on the UX view on this :-)
Comment 3 Eike Rathke 2020-06-02 15:09:30 UTC
Fwiw, also Firefox closes the window (or even the application) if it was the last tab to be closed (or last tab on last window).
Comment 4 Heiko Tietze 2020-06-04 13:01:25 UTC
+ browsers close (FF & Chromium), editors don't (Kate)
+ see also https://wiki.mozilla.org/Ctrl_W_not_close_app
+ about:config -> browser.tabs.closeWindowWithLastTab
+ ctrl+w actually goes back to start center, which closes then per ctrl+w

=> putting all together it's a WFM