Bug 133556 - Deleting a column with tracking changes enabled slow
Summary: Deleting a column with tracking changes enabled slow
Status: RESOLVED DUPLICATE of bug 133267
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, perf, regression
Depends on:
Blocks:
 
Reported: 2020-05-31 15:44 UTC by Telesto
Modified: 2020-06-08 11:54 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Example file (1.75 MB, application/vnd.oasis.opendocument.spreadsheet)
2020-05-31 15:45 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-05-31 15:44:53 UTC
Description:
Deleting a column with tracking changes enabled slow

Steps to Reproduce:
1. Open the attached file
2. Enable tracking changes
3. Delete column D
4. Delete column E (Ref error column) -> Slow

Actual Results:
Slow takes 40 seconds or so

Expected Results:
Instantaneous 


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 83c4f86f22dc37269ac6a038fe7de053c42aad6e
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: en-US (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-05-31 15:45:21 UTC
Created attachment 161462 [details]
Example file
Comment 2 Telesto 2020-05-31 15:46:02 UTC
Bisected to
author	Henry Castro <hcastro@collabora.com>	2018-06-26 23:32:41 -0400
committer	Eike Rathke <erack@redhat.com>	2018-06-27 13:44:07 +0200
commit	b9652803096b68a33702601aac52e78c8a4250c6 (patch)
tree	1ed7822221824417039126b7db04a8b37ebeaee8
parent	b262e6e5da0c2e66e00cd6d68d7c2df11a34ff5c (diff)
tdf#118308: Incorrect Paste Special dialog when ...
pasting content from another cell

In tiled rendering case (headless) each window has its own clipboard,
otherwise exists a unique clipboard (UNO service).
Comment 3 Luboš Luňák 2020-06-08 10:33:35 UTC
This is probably a duplicate of bug #133267 too.
Comment 4 Telesto 2020-06-08 11:54:16 UTC

*** This bug has been marked as a duplicate of bug 133267 ***