Bug 133577 - Automatically insert heading before endnotes
Summary: Automatically insert heading before endnotes
Status: RESOLVED DUPLICATE of bug 89736
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.4.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Footnote-Endnote HTML-Export EPUB-Export
  Show dependency treegraph
 
Reported: 2020-06-01 10:18 UTC by Bruce Armstrong
Modified: 2020-08-26 13:52 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of footnotes and endnotes using Lector (142.91 KB, image/png)
2020-06-04 08:50 UTC, Heiko Tietze
Details
Sample document (82.51 KB, application/vnd.oasis.opendocument.text)
2020-06-04 08:52 UTC, Heiko Tietze
Details
Sample export (58.83 KB, application/epub+zip)
2020-06-04 08:53 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bruce Armstrong 2020-06-01 10:18:53 UTC
Description:
Inserting an Endnote heading in the HTML and ebook chapters where the footnote/endnotes begin, as there is currently nothing to demarcate them. 

Steps to Reproduce:
1.Export an odt with footnotes to HTML or epub
2.Look where the endnotes begin: there is no heading, they just begin.
3.

Actual Results:
No heading

Expected Results:
Should have a heading


Reproducible: Always


User Profile Reset: No



Additional Info:
Not necessary, but more elegant.
Comment 1 Dieter 2020-06-03 15:07:11 UTC
I confirm the decsribed behaviour with

Version: 7.0.0.0.beta1 (x64)
Build ID: 94f789cbb33335b4a511c319542c7bdc31ff3b3c
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

cc: Design-Team for further input and decision
Comment 2 Heiko Tietze 2020-06-04 08:50:49 UTC
Created attachment 161599 [details]
Screenshot of footnotes and endnotes using Lector

As endnotes are always placed on an extra page it makes sense to have a heading on top. This request has been made in bug 89736 and I would make this a duplicate.

The situation is worse for special formats without defined page breaks such as epub. Plus, the endnote are attached to the chapter not the document. Is this by design?
Comment 3 Heiko Tietze 2020-06-04 08:52:42 UTC
Created attachment 161600 [details]
Sample document
Comment 4 Heiko Tietze 2020-06-04 08:53:00 UTC
Created attachment 161601 [details]
Sample export
Comment 5 Heiko Tietze 2020-06-04 08:53:49 UTC
(In reply to Heiko Tietze from comment #2)
> Plus, the endnote are attached to the chapter not the document. Is
> this by design?

What do you think, Miklos?
Comment 6 Dieter 2020-06-04 09:00:27 UTC
(In reply to Heiko Tietze from comment #2)
> As endnotes are always placed on an extra page it makes sense to have a
> heading on top. This request has been made in bug 89736 and I would make
> this a duplicate.

Heiko, I don't think this is a duplicate, beacause enhancement request here is about footnotes that will become endnotes in Epub-Export. If I understand the proposal corecct, the Epub-Export (or html export) should create a heading for endnotes.
Comment 7 Miklos Vajna 2020-06-04 09:00:57 UTC
We offload our odf export result to libepubgen to actually create the EPUB output, probably libepubgen does this. Given that Writer always puts enonotes to the end of the document, it would make sense to improve libepubgen to allow a mode to put them to the end of the doc + make LO use this mode.
Comment 8 Bruce Armstrong 2020-06-08 01:12:43 UTC
Writer needs to continue to offer the ability to use both footnotes and endnotes.
But footnotes are converted to endnotes that go to the end of the document in the HTML export and the end of each chapter in the Ebook Export. As they are now effectively Endnotes, it would be nice to have a heading inserted for them that marks them as Endnotes.
Comment 9 Heiko Tietze 2020-06-14 12:09:09 UTC
So let's automatically insert a heading before the first endnote, but only if none have been added. That should allow to delete this heading and to not add it back. It might be also worth to have a setting "Insert heading before Endnotes" under Tools > Options > Writer > Formatting Aids to make everybody happy.
Comment 10 Cor Nouws 2020-08-26 13:52:16 UTC
I think having the option to add one (bug 89736) makes most sense and covers all use cases. So closing this one as dup.

*** This bug has been marked as a duplicate of bug 89736 ***