Bug 133579 - Icons/buttons hard to see when using dark system theme.
Summary: Icons/buttons hard to see when using dark system theme.
Status: RESOLVED DUPLICATE of bug 127138
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.4.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-01 11:39 UTC by Daniel Massey
Modified: 2020-06-12 11:44 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
Proof screenshot (17.15 KB, image/png)
2020-06-01 11:40 UTC, Daniel Massey
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Massey 2020-06-01 11:39:29 UTC
Description:
The icons and buttons in LibreOffice are hard to see when my system theme is dark. I am using Kubuntu 20.04 LTS, KDE Plasma desktop, with the Breeze-dark theme for both Qt and Gtk applications. This makes all applications have a dark theme which I like, however I would expect the icons in LibreOffice to turn white to be visible (like they do with other applications). Instead, they stay black so it's black on dark grey which is hard to see. I will attach a screenshot so you can see.

Steps to Reproduce:
1. Go to Plasma System Settings --> Global Theme --> Select "Breeze Dark" --> Save and Apply
2. Log out of the session and then log back in (for the changes to take effect better).
3. Launch LibreOffice (Writer, in my case).

Actual Results:
Icons appear black on a dark-grey background, so hard to see.

Expected Results:
I would expect the icons to appear white, so they would be more visible.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Version: 6.4.3.2
Build ID: 1:6.4.3-0ubuntu0.20.04.1
CPU threads: 4; OS: Linux 5.6; UI render: default; VCL: kf5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-GB
Calc: threaded
Comment 1 Daniel Massey 2020-06-01 11:40:59 UTC
Created attachment 161487 [details]
Proof screenshot

Proof screenshot of dark, hard-to-see icons
Comment 2 Mihkel Tõnnov 2020-06-12 11:44:44 UTC

*** This bug has been marked as a duplicate of bug 127138 ***