Bug 133582 - Tools > Options has no check boxes
Summary: Tools > Options has no check boxes
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha1+
Hardware: x86-64 (AMD64) All
: high major
Assignee: Rizal Muttaqin
URL:
Whiteboard: target:7.1.0 target:7.0.0.1 target:6.4.6
Keywords: bibisected, bisected, regression
: 133598 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-06-01 13:05 UTC by Regina Henschel
Modified: 2020-07-15 08:28 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Tools > Options > LibreOffice > Print (13.69 KB, image/png)
2020-06-01 13:05 UTC, Regina Henschel
Details
Tools > Options > Draw > General (12.37 KB, image/png)
2020-06-01 13:09 UTC, Regina Henschel
Details
Missing checkboxes in autofilter dialogue (Calc) (383.25 KB, image/jpeg)
2020-06-02 21:57 UTC, Stefan_Lange_KA@T-Online.de
Details
Missing checkboxes in Format Paragraph dialogue (Writer) (502.31 KB, image/jpeg)
2020-06-02 21:58 UTC, Stefan_Lange_KA@T-Online.de
Details
screenshot with gen rendering (135.97 KB, image/png)
2020-06-03 11:03 UTC, Julien Nabet
Details
6.4 Version with Gen Env (175.27 KB, image/png)
2020-06-03 11:15 UTC, Rizal Muttaqin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2020-06-01 13:05:53 UTC
Created attachment 161491 [details]
Tools > Options > LibreOffice > Print

The settings in Tools > Options have no check boxes, see attached screenshots.

I see the error in Version: 7.1.0.0.alpha0+ (x64)
Build ID: a0c90f1bccd9b5a349d3199746facab549f27dba
CPU threads: 8; OS: Windows 10.0 Build 18362; UI render: Skia/Raster; VCL: win
Locale: de-DE (en_US); UI: en-US
Calc: CL

I have tested it with a new user profile.
Comment 1 Regina Henschel 2020-06-01 13:09:52 UTC
Created attachment 161492 [details]
Tools > Options > Draw > General

And another screen shot from Tools > Options > LibreOfficeDev Draw > General.
Comment 2 Xisco Faulí 2020-06-01 13:55:05 UTC
Not reproducible in

Version: 7.0.0.0.beta1+
Build ID: 2506d8221dd940dfd93d3d7c183430ba6ba3089d
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: x11
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Regina, do you reproduce it without skia ?
Comment 3 Regina Henschel 2020-06-01 14:26:44 UTC
I the error too if Skia is disabled.
Comment 4 V Stuart Foote 2020-06-01 17:43:34 UTC
Confirmed. Disabling Skia rendering does not resolve check-boxes missing from the Tools -> Options

2020-06-01 TB77 x64 build.

Version: 7.1.0.0.alpha0+ (x64)
Build ID: a0c90f1bccd9b5a349d3199746facab549f27dba
CPU threads: 8; OS: Windows 10.0 Build 18362; UI render: default; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL
Comment 5 Maxim Monastirsky 2020-06-02 08:19:21 UTC
Confirmed also in:

Version: 7.1.0.0.alpha0+
Build ID: a0c90f1bccd9b5a349d3199746facab549f27dba
CPU threads: 4; OS: Linux 5.6; UI render: default; VCL: x11
Locale: en-US (en_US.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-06-01_02:36:12
Calc: threaded
Comment 6 Julien Nabet 2020-06-02 10:03:36 UTC
On Win10 with master sources updated today, I could reproduce this.

I noticed these logs:
warn:vcl:10520:16224:vcl/source/window/menu.cxx:2940: Available height misdetected as 593px. Setting to 768px instead.
warn:vcl:10520:16224:vcl/source/gdi/bitmapex.cxx:111: BitmapEx::BitmapEx(): could not load image vcl/res/check1.png via icon theme colibre
warn:vcl:10520:16224:vcl/source/gdi/bitmapex.cxx:111: BitmapEx::BitmapEx(): could not load image vcl/res/check2.png via icon theme colibre
warn:vcl:10520:16224:vcl/source/gdi/bitmapex.cxx:111: BitmapEx::BitmapEx(): could not load image vcl/res/check3.png via icon theme colibre
warn:vcl:10520:16224:vcl/source/gdi/bitmapex.cxx:111: BitmapEx::BitmapEx(): could not load image vcl/res/check4.png via icon theme colibre
warn:vcl:10520:16224:vcl/source/gdi/bitmapex.cxx:111: BitmapEx::BitmapEx(): could not load image vcl/res/check5.png via icon theme colibre
warn:vcl:10520:16224:vcl/source/gdi/bitmapex.cxx:111: BitmapEx::BitmapEx(): could not load image vcl/res/check6.png via icon theme colibre
warn:vcl:10520:16224:vcl/source/gdi/bitmapex.cxx:111: BitmapEx::BitmapEx(): could not load image vcl/res/check7.png via icon theme colibre
warn:vcl:10520:16224:vcl/source/gdi/bitmapex.cxx:111: BitmapEx::BitmapEx(): could not load image vcl/res/check8.png via icon theme colibre
warn:vcl:10520:16224:vcl/source/gdi/bitmapex.cxx:111: BitmapEx::BitmapEx(): could not load image vcl/res/check9.png via icon theme colibre
warn:vcl:10520:16224:vcl/source/gdi/bitmapex.cxx:111: BitmapEx::BitmapEx(): could not load image vcl/res/radio1.png via icon theme colibre
warn:vcl:10520:16224:vcl/source/gdi/bitmapex.cxx:111: BitmapEx::BitmapEx(): could not load image vcl/res/radio2.png via icon theme colibre
warn:vcl:10520:16224:vcl/source/gdi/bitmapex.cxx:111: BitmapEx::BitmapEx(): could not load image vcl/res/radio3.png via icon theme colibre
warn:vcl:10520:16224:vcl/source/gdi/bitmapex.cxx:111: BitmapEx::BitmapEx(): could not load image vcl/res/radio4.png via icon theme colibre
warn:vcl:10520:16224:vcl/source/gdi/bitmapex.cxx:111: BitmapEx::BitmapEx(): could not load image vcl/res/radio5.png via icon theme colibre
warn:vcl:10520:16224:vcl/source/gdi/bitmapex.cxx:111: BitmapEx::BitmapEx(): could not load image vcl/res/radio6.png via icon theme colibre
Comment 7 Julien Nabet 2020-06-02 10:11:29 UTC
Regression + all envs + easily noticeable => increase importance/priority.
Comment 8 Xisco Faulí 2020-06-02 11:20:22 UTC
*** Bug 133598 has been marked as a duplicate of this bug. ***
Comment 9 Julien Nabet 2020-06-02 11:40:25 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this with gen rendering.
I don't reproduce this with gtk3 or kf5.

(VStuart/Xisco: automatic completion to add someone in CC doesn't work for me, is it the same for you?)
Comment 10 Julien Nabet 2020-06-02 11:42:15 UTC
I also noticed that:
- in gtk3 nothing special in console
- in kf5, whereas checkboxes are displayed, I got these logs:
warn:vcl:43738:43738:vcl/source/gdi/bitmapex.cxx:111: BitmapEx::BitmapEx(): could not load image vcl/res/check1.png via icon theme elementary
warn:vcl:43738:43738:vcl/source/gdi/bitmapex.cxx:111: BitmapEx::BitmapEx(): could not load image vcl/res/check2.png via icon theme elementary
warn:vcl:43738:43738:vcl/source/gdi/bitmapex.cxx:111: BitmapEx::BitmapEx(): could not load image vcl/res/check3.png via icon theme elementary
warn:vcl:43738:43738:vcl/source/gdi/bitmapex.cxx:111: BitmapEx::BitmapEx(): could not load image vcl/res/check4.png via icon theme elementary
Comment 11 Julien Nabet 2020-06-02 12:27:07 UTC
Caolán: thought you might be interested in this one since it concerns vcl/rendering.
Comment 12 Xisco Faulí 2020-06-02 12:56:20 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=263e5726c71b3c3579f974194510ed01947ee6cf

author	Rizal Muttaqin <riz_17_oke@yahoo.co.id>	2020-05-30 21:21:26 +0700
committer	Adolfo Jayme Barrientos <fitojb@ubuntu.com>	2020-05-31 20:48:11 +0200
commit	263e5726c71b3c3579f974194510ed01947ee6cf (patch)
tree	5e5962554f8c1d052e49756a15a630852ebb9ec2
parent	bfbf745470cb6f99532523fdeffca061b37d8393 (diff)
Resolves tdf#133268: Update Colibre color palette

Bisected with: bibisect-linux64-7.1

Adding Cc: to Rizal Muttaqin
Comment 13 Caolán McNamara 2020-06-02 13:00:31 UTC
I commented earlier today in the gerrit review of the bisected commit that this problem exists, the bitmaps of the checkboxes (for gen) got removed in that commit so the bisect is correct
Comment 14 V Stuart Foote 2020-06-02 13:04:36 UTC
(In reply to Julien Nabet from comment #9)
> 
> (VStuart/Xisco: automatic completion to add someone in CC doesn't work for
> me, is it the same for you?)

@Xisco, definite issues with BZ slow or not responding to CC lookup/autocomplete
Comment 15 Julien Nabet 2020-06-02 13:13:32 UTC
(In reply to Caolán McNamara from comment #13)
> I commented earlier today in the gerrit review of the bisected commit that
> this problem exists, the bitmaps of the checkboxes (for gen) got removed in
> that commit so the bisect is correct

Indeed, I see this in https://gerrit.libreoffice.org/c/core/+/95189.
Sorry for the noise :-(
Comment 16 Stefan_Lange_KA@T-Online.de 2020-06-02 21:57:25 UTC
Created attachment 161554 [details]
Missing checkboxes in autofilter dialogue (Calc)

Seems the checkboxes are not only missing in Options dialogues but in all dialogues, see e.g. attached screenshots of a filter dialogue (Calc) or Format Paragraph dialogue (Writer).
Comment 17 Stefan_Lange_KA@T-Online.de 2020-06-02 21:58:27 UTC
Created attachment 161555 [details]
Missing checkboxes in Format Paragraph dialogue (Writer)
Comment 18 Commit Notification 2020-06-03 05:39:32 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/78da6e80efb009b28625fb081617c8044b20f790

Fix for tdf#133582, missing checkbox in gen env

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Julien Nabet 2020-06-03 09:58:55 UTC
On Win10 with master sources updated today, I don't reproduce this anymore.
Thank you Rizal! :-)
Comment 20 Commit Notification 2020-06-03 10:06:26 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/adf34e587b6373f17bf122d3d810fdae89a7c7dd

Fix for tdf#133582, missing checkbox in gen env

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Rizal Muttaqin 2020-06-03 10:11:01 UTC
(In reply to Julien Nabet from comment #19)
> On Win10 with master sources updated today, I don't reproduce this anymore.
> Thank you Rizal! :-)

and now we have SVG version. You are welcome...
Comment 22 Julien Nabet 2020-06-03 11:03:03 UTC
Created attachment 161563 [details]
screenshot with gen rendering

On pc Debian x86-64 with master sources updated today + gen rendering, I confirm it works now.

nitpick: I noticed that background of checkboxes is yellowish (see screenshot), I don't know if it's expected.
Comment 23 Rizal Muttaqin 2020-06-03 11:15:43 UTC
Created attachment 161564 [details]
6.4 Version with Gen Env

In 6.4 version, it used to be white while the PNG icon actually yellow. I change the yellow color a bit to follow new Monoline palette. Should I change it to use previous one?
Comment 24 Julien Nabet 2020-06-03 11:47:13 UTC
(In reply to Rizal Muttaqin from comment #23)
> Created attachment 161564 [details]
> 6.4 Version with Gen Env
> 
> In 6.4 version, it used to be white while the PNG icon actually yellow. I
> change the yellow color a bit to follow new Monoline palette. Should I
> change it to use previous one?

I'll let UI people speak here.
Comment 25 Stefan_Lange_KA@T-Online.de 2020-06-04 09:13:48 UTC
Test was OK with both
Version: 7.0.0.0.beta1+ (x64)
Build ID: 8c08eefeb512d4cbc86c4c5308d86a59bd232beb
CPU-Threads: 4; BS: Windows 10.0 Build 19640; UI-Render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: CL
and
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 191288d6a7fb52b31038a21c4e71ee57ffa3bacd
CPU-Threads: 4; BS: Windows 10.0 Build 19640; UI-Render: Skia/Vulkan; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: threaded
Comment 26 Commit Notification 2020-06-09 10:04:06 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/dcc031d0cd3219dd77b66e1221fe966139829c1a

Icon theme: tdf#133582 missing checkbox and radio button in gen env

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 27 Rizal Muttaqin 2020-06-09 10:10:00 UTC
(In reply to Commit Notification from comment #26)
> Rizal Muttaqin committed a patch related to this issue.
> It has been pushed to "master":
> 
> https://git.libreoffice.org/core/commit/
> dcc031d0cd3219dd77b66e1221fe966139829c1a
> 
> Icon theme: tdf#133582 missing checkbox and radio button in gen env
> 
> It will be available in 7.1.0.
> 
> The patch should be included in the daily builds available at
> https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
> information about daily builds can be found at:
> https://wiki.documentfoundation.org/Testing_Daily_Builds
> 
> Affected users are encouraged to test the fix and report feedback.

Now all icon themes will have their own checkboxs and radio buttons.
Comment 28 Caolán McNamara 2020-06-09 10:17:28 UTC
I'm a little concerned that the tristate "inconsistent" image seems to be the same as the checked image, but with a different background ? In the past IIRC this was something that looked like either an "X" or a "-"
Comment 29 Rizal Muttaqin 2020-06-09 10:20:44 UTC
(In reply to Caolán McNamara from comment #28)
> I'm a little concerned that the tristate "inconsistent" image seems to be
> the same as the checked image, but with a different background ? In the past
> IIRC this was something that looked like either an "X" or a "-"

Could you please give a screenshot comparison? I used old PNG files as references.
Comment 30 Xisco Faulí 2020-06-09 11:00:50 UTC
(In reply to Caolán McNamara from comment #28)
> I'm a little concerned that the tristate "inconsistent" image seems to be
> the same as the checked image, but with a different background ? In the past
> IIRC this was something that looked like either an "X" or a "-"

I've checked with previous versions and it seems it has been the case since at least

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

I'll report a follow-up enhancement to deal with it. Gtk3 displays (-) which makes more sense imho
Comment 31 Xisco Faulí 2020-06-09 11:16:46 UTC
(In reply to Xisco Faulí from comment #30)
> (In reply to Caolán McNamara from comment #28)
> > I'm a little concerned that the tristate "inconsistent" image seems to be
> > the same as the checked image, but with a different background ? In the past
> > IIRC this was something that looked like either an "X" or a "-"
> 
> I've checked with previous versions and it seems it has been the case since
> at least
> 
> Version: 4.3.0.0.alpha1+
> Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e
> 
> I'll report a follow-up enhancement to deal with it. Gtk3 displays (-) which
> makes more sense imho

Reported in bug 133819
Comment 32 Caolán McNamara 2020-06-09 11:29:46 UTC
(In reply to Rizal Muttaqin from comment #29)
> Could you please give a screenshot comparison? I used old PNG files as
> references.

ah, I'm wrong for the gen case. It was a grayed out check-mark for the inconsistent state so had the same check shape for inconsistent vs true. Though bug 133819 is still a good idea.
Comment 33 Commit Notification 2020-06-09 22:36:46 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/22cb73dcc682edb15a2425339377ff54dde5dba6

Icon theme: tdf#133582 tdf#133038

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 34 Xisco Faulí 2020-06-16 15:31:26 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: 11d21b3c1f7754b5d13ae9ea88da562ec74366ff
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: x11
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Rizal, thanks for fixing this issue!
Comment 35 Commit Notification 2020-06-27 04:04:59 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/4842d8f51fe5b6d8b3e8dca559b7fac550f14fbe

Karasa Jaga: tdf#133753, tdf#133582, tdf#106229

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 36 Commit Notification 2020-06-27 06:58:21 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/622bf0d6695e61b73312289a228e29b92ca842b3

Karasa Jaga: tdf#133753, tdf#133582, tdf#106229

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 37 Commit Notification 2020-07-15 08:28:56 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/4686219d9fcd0dfb3de1937079458cbc439f13a6

Breeze: tdf#126122, tdf#133038, tdf#133582

It will be available in 6.4.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.