Bug 133592 - LibreOffice 7.0.0.0 beta1 crashes when draging a .png image into a new document
Summary: LibreOffice 7.0.0.0 beta1 crashes when draging a .png image into a new document
Status: RESOLVED DUPLICATE of bug 133365
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected
Depends on:
Blocks:
 
Reported: 2020-06-02 01:04 UTC by clay0
Modified: 2020-06-09 11:55 UTC (History)
3 users (show)

See Also:
Crash report or crash signature: e886e501-bd29-413b-b02a-d3aa4276d42f


Attachments
One of the .png files that causes LO 7 beta1 to crash. (29.02 KB, image/png)
2020-06-02 19:18 UTC, clay0
Details

Note You need to log in before you can comment on or make changes to this bug.
Description clay0 2020-06-02 01:04:54 UTC
Description:
LibreOffice 7.0.0.0 beta1 crashes every time when trying to insert a .png image into a new LibreOffice document, be it in Draw, in Impress or in Writer.

Steps to Reproduce:
1.Create a new Draw, Impress or Writer document.
2.Try to insert a .png image.
3.That's it.

Actual Results:
LibreOffice 7.0.0.0 beta1 immediately crashes.


Expected Results:
No crashes expected.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Build: 94f789cbb33335b4a511c319542c7bdc31ff3b3c
OS: Xubuntu 20.04
Linux: 5.4.0-33-generic
See:
crashreport.libreoffice.org/stats/crash_details/7eeac802-c16a-429c-968b-e3b71e773ef5
also:
crashreport.libreoffice.org/stats/crash_details/7ca6d2f6-ed66-4f82-a78a-5a0583ad4ad1
(This second crash in "safe mode".)
also:
crashreport.libreoffice.org/stats/crash_details/45a35de4-4938-4a29-80bd-652a10077eee
also in Impress:
crashreport.libreoffice.org/stats/crash_details/e886e501-bd29-413b-b02a-d3aa4276d42f
also in Writer:
crashreport.libreoffice.org/stats/crash_details/570ac7ac-b385-42c6-9b23-f5f90fa23c46
also in Writer:
crashreport.libreoffice.org/stats/crash_details/1ad629e9-022a-45fd-b6f5-ab32d7585c7a
and also in Writer:
crashreport.libreoffice.org/stats/crash_details/b85284e8-3cef-4ec7-8f1b-a2de1cfc36ec
These last five crashes under a new user profile. And the last crash using a newly created and already saved nearly empty .odt document. All the other crashes happened when the newly created document hadn't even been saved for once.
Comment 1 clay0 2020-06-02 05:58:46 UTC
Of these seven crashes the first three were in LibreOffice Draw.
Comment 2 Assao Alu 2020-06-02 06:31:47 UTC
I have try the bug to confirm (with WRITER AND DRAW) and i found that now it is not reproducible on my side. i tested it on the alpha version 7.0.0.0 beta1 and the version 6.4.4.2.

Version: 7.0.0.0.alpha1 (x64)
Build ID: 6a03b2a54143a9bc0c6d4c7f1...
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: Skia/Vulkan; VCL: win; 
Locale: en-US (en_US); UI: en-US
Calc: threaded.

Version: 6.4.4.2 (x64)
Build ID: 3d775be2011f3886db32dfd395a6a6d1ca2630ff
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: GL; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded.
Comment 3 clay0 2020-06-02 07:26:56 UTC
(In reply to Assao Alu from comment #2)
> I have try the bug to confirm (with WRITER AND DRAW) and i found that now it
> is not reproducible on my side. i tested it on the alpha version 7.0.0.0
> beta1 and the version 6.4.4.2.
> 
> Version: 7.0.0.0.alpha1 (x64)
> Build ID: 6a03b2a54143a9bc0c6d4c7f1...
> CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: Skia/Vulkan; VCL:
> win; 
> Locale: en-US (en_US); UI: en-US
> Calc: threaded.
> 
> Version: 6.4.4.2 (x64)
> Build ID: 3d775be2011f3886db32dfd395a6a6d1ca2630ff
> CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: GL; VCL: win; 
> Locale: en-US (en_US); UI-Language: en-US
> Calc: threaded.

It's only about version 7.0.0.0 beta1. I haven't tried with any alpha version. And the stable versions ("still" and "fresh") are OK.
Comment 4 Xisco Faulí 2020-06-02 09:09:31 UTC
I can't reproduce it in

Version: 7.0.0.0.beta1+
Build ID: 2506d8221dd940dfd93d3d7c183430ba6ba3089d
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

Does it happen with a particular .png or with any .png file?
Comment 5 Xisco Faulí 2020-06-02 09:09:50 UTC
OTOH, Could you please paste the info from Help - about LibreOffice ?
Comment 6 clay0 2020-06-02 19:18:26 UTC
Created attachment 161547 [details]
One of the .png files that causes LO 7 beta1 to crash.
Comment 7 clay0 2020-06-02 19:20:21 UTC
(In reply to Xisco Faulí from comment #4)
> I can't reproduce it in
> 
> Version: 7.0.0.0.beta1+
> Build ID: 2506d8221dd940dfd93d3d7c183430ba6ba3089d
> CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
> Locale: en-US (en_US.UTF-8); UI: en-US
> Calc: threaded
> 
> Does it happen with a particular .png or with any .png file?

It seems to happen with any .png file. I've attached one of them.
Crash in Writer:
crashreport.libreoffice.org/stats/crash_details/835ee42a-9955-49bc-9695-727c695b43b8
Comment 8 clay0 2020-06-02 19:26:15 UTC
(In reply to Xisco Faulí from comment #5)
> OTOH, Could you please paste the info from Help - about LibreOffice ?

Version: 7.0.0.0.beta1
Build ID: 94f789cbb33335b4a511c319542c7bdc31ff3b3c
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

And the following help packs and language packs are also installed:
en-US: help pack
en-GB: help pack and language pack
es-ES: help pack and language pack
de: help pack and language pack
eo: help pack and language pack
Comment 9 QA Administrators 2020-06-03 03:49:41 UTC Comment hidden (obsolete)
Comment 10 clay0 2020-06-03 07:54:47 UTC
Now I've also tried with .jpg and .gif files and it's exactly the same as with .png files: LO 7 beta1 just crashes.

I've also installed another instance of LO 7 beta1 in parallel (in Xubuntu, but this time without any help pack or language pack) with exactly the same outcome.

I've also installed LO 7 beta1 in Windows 10 with no crashes at all there, trying with .png, .jpg and .gif files.

And another crash report (Draw):
crashreport.libreoffice.org/stats/crash_details/fc95828e-3ef8-4bd8-815c-687c736da09c
Comment 11 clay0 2020-06-03 08:30:05 UTC
All of these crashes happened while trying to drag an image file into a document. Now I've inserted the image files using the menu "Insert" --> "Image..." and NO crashes happen this way.
Comment 12 clay0 2020-06-06 08:55:45 UTC
The following installation works perfectly OK when dragging image files (.png, .jpg, .gif) into a document (Writer, Calc, Impress, Draw), both on Xubuntu 20.04 and on Ubuntu Budgie 20.04:

Version: 7.0.0.0.alpha1
Build ID: 6a03b2a54143a9bc0c6d4c7f190b77cdc5a14733
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

The following installation crashes every time when dragging image files (.png, .jpg, .gif) into a document (Writer, Calc, Impress, Draw), both on Xubuntu 20.04 and on Ubuntu Budgie 20.04:

Version: 7.0.0.0.beta1
Build ID: 94f789cbb33335b4a511c319542c7bdc31ff3b3c
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 13 raal 2020-06-06 10:18:27 UTC
no crash Version: 7.0.0.0.beta1+
Build ID: c344de1b9985b6ca10b354e24151d0bdf92dc20e
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: cs-CZ (cs_CZ.UTF-8); UI: en-US
Calc: threaded
Ubuntu 18.04
Comment 14 Timur 2020-06-09 11:55:35 UTC
I reproduced in Linux with 7.1+ oldest but seems to be fixed in master. 

a97831b8bf3e889bbc3af077d3fb417d32f4fd0b is the first *good* commit
commit a97831b8bf3e889bbc3af077d3fb417d32f4fd0b
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Tue Jun 2 03:16:21 2020 +0200

    source sha:80c9fae6aa8638e192e5b622d12305b304890b43
Previous source sha: 270005fe2fb594d1894305c742f98b53367f4dd3.

https://gerrit.libreoffice.org/plugins/gitiles/core/+/80c9fae6aa8638e192e5b622d12305b304890b43%5E!/

commit	80c9fae6aa8638e192e5b622d12305b304890b43	[log]
author	Mike Kaganski <mike.kaganski@collabora.com>	Fri May 29 10:53:47 2020 +0200
committer	Mike Kaganski <mike.kaganski@collabora.com>	Sat May 30 20:49:16 2020 +0200
tree	e8ad75c5a79ccf4fdf2077d6e51a70ecd59766ec
parent	270005fe2fb594d1894305c742f98b53367f4dd3 [diff]

tdf#133365: only release solar mutex on Windows

Regression after f2561331534459f8aebc57e8615fa5f626521bcb

Change-Id: Id12a81b2ca79edb7ae056b357dcfd1d8f4bb56ef
Reviewed-on: https://gerrit.libreoffice.org/c/core/+/95088
Tested-by: Jenkins
Tested-by: Xisco Fauli <xiscofauli@libreoffice.org>
Reviewed-by: Jean-Baptiste Faure <jbfaure@libreoffice.org>
Reviewed-by: Mike Kaganski <mike.kaganski@collabora.com>

*** This bug has been marked as a duplicate of bug 133365 ***