Bug 133597 - Feature Request: Typeface/Font Selection for Math/Formula or correction of few characters
Summary: Feature Request: Typeface/Font Selection for Math/Formula or correction of fe...
Status: RESOLVED DUPLICATE of bug 101174
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-02 10:42 UTC by Georg Müller
Modified: 2020-06-02 19:38 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Georg Müller 2020-06-02 10:42:34 UTC
Description:
The Formula Editor LibreOffice Math provides an option to edit the default typefaces of variables, functions, numbers and text. Unfortunately operators are not affected by any of those categories. Few operators are not locking that pretty, especially +, -> (rightarrow), <- (leftarrow), => (drarrow), <= (dlarrow).

It would be awesome, if this could be fixed, either by changing the typeface of those particular characters or even better by an 5th option to chose the typeface for operators. That + doesn't fit to the rest of the operators becomes obvious by comparing + and – (minus). The lines of the plus are much heavier than the line of minus.

Steps to Reproduce:
1. Open LibreOffice Math
2. Type "a+b-c -> d <- e" and compare +, – (minus), -> (rightarrow) and -> (leftarrow)

Actual Results:
Lineweight of plus operator and arrows is much heavier than expected

Expected Results:
plus and minus have same line weight/fontface. Could be fixed easy by modification of typeface (+) or character (->, <-).


Reproducible: Always


User Profile Reset: No



Additional Info:
I wanted to replace the typeface with CMU serif (Computer Modern by D. E. Knuth) (https://www.fontsquirrel.com/fonts/computer-modern). I guess all operators are predefined and can not be changed. Would be nice to correct the misfitting characters or even better to have an option to choose a typeface.
Comment 1 V Stuart Foote 2020-06-02 15:40:08 UTC
The specific case is our OpenSymbol glyph chart, see bug 103740 but the request in general is issue of bug 101174

You can currently make a Tool -> Options -> Fonts 'Replacement Table' assignment to replace OpenSymbol with a more appealing font with Unicode coverage of the misc mathematical and greek symbols--YMMV

*** This bug has been marked as a duplicate of bug 101174 ***
Comment 2 Georg Müller 2020-06-02 19:38:52 UTC
Thanks for the hint. Unfortunately a simple replacement with a font like Computer Modern does not work, because the character mapping doesn't work well. I found the font FreeSerif, which is not pretty, but at least the character mapping works almost well. In comparison to OpenSymbol, the symbols are more persistent.