Bug 133623 - Setting different Border Styles for the same cell with the toolbar button
Summary: Setting different Border Styles for the same cell with the toolbar button
Status: RESOLVED DUPLICATE of bug 103770
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.4.2 release
Hardware: x86-64 (AMD64) All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2020-06-03 04:59 UTC by putude
Modified: 2020-06-25 10:30 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample table (12.19 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-06-24 16:07 UTC, putude
Details

Note You need to log in before you can comment on or make changes to this bug.
Description putude 2020-06-03 04:59:05 UTC
Description:
Inconsistent styling border Calc on spesific side cell. 

Steps to Reproduce:
1.Open Calc
2.Select Borders (all side)
3.Select Borders (bottom side)
4.Select Border Style

Actual Results:
Style applied in all side of borders

Expected Results:
Style applied in bottom side only


Reproducible: Always


User Profile Reset: Yes



Additional Info:
The application should remember the last selected border. Applied the selected border only. The Border Style in toolbar should similar in Format Cell Window.
Comment 1 aadijain 2020-06-19 01:07:59 UTC Comment hidden (obsolete)
Comment 2 Buovjaga 2020-06-22 11:54:11 UTC
Putude: do you mean that at step 3, it should clear the previously set "All sides" borders and replace with "Bottom side" for the selection?
Comment 3 putude 2020-06-24 15:42:36 UTC
(In reply to Buovjaga from comment #2)
> Putude: do you mean that at step 3, it should clear the previously set "All
> sides" borders and replace with "Bottom side" for the selection?

Yes, I mean it should be effected only on the bottom side, not all borders. 
Let say, I make 5 rows, 5 cols of the table. I want to make it bordered with a single-line style, except for the first row (table header). I want to apply a double-line style on the bottom only. 
It can be done by using Format Cells, but border-styles on Format Cell Window are different from the toolbar. Thanks.
Comment 4 Buovjaga 2020-06-24 15:51:19 UTC
(In reply to putude from comment #3)
> (In reply to Buovjaga from comment #2)
> > Putude: do you mean that at step 3, it should clear the previously set "All
> > sides" borders and replace with "Bottom side" for the selection?
> 
> Yes, I mean it should be effected only on the bottom side, not all borders. 
> Let say, I make 5 rows, 5 cols of the table. I want to make it bordered with
> a single-line style, except for the first row (table header). I want to
> apply a double-line style on the bottom only. 
> It can be done by using Format Cells, but border-styles on Format Cell
> Window are different from the toolbar. Thanks.

Please attach an example file where you have formatted the borders using the Format Cell dialog. I want to be 100% sure I understand.
Comment 5 putude 2020-06-24 16:07:16 UTC
Created attachment 162381 [details]
Sample table

Here is the example.
Comment 6 Buovjaga 2020-06-24 16:37:44 UTC
Thanks, now I get it.

I found this report that is somewhat related: bug 103770.

This seems like a difficult thing to solve. I don't remember how Excel handles this case (or does it?). Let's ask the UX team for advice.
Comment 7 Heiko Tietze 2020-06-25 10:30:21 UTC
Obviously the widget adds the border and never toggles. Thus checking all borders means that you cannot remove the bottom line. If we change this, it wouldn't be possible anymore to have a line on top and left, for example. But in fact it's the same request as the mentioned ticket. So let's continue there.

*** This bug has been marked as a duplicate of bug 103770 ***