Download it now!
Bug 133662 - French translation missing in 'help' menu and in 'about LibreOfficeDev' window
Summary: French translation missing in 'help' menu and in 'about LibreOfficeDev' window
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.1.0 target:7.0.0.1
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-04 08:30 UTC by jeandubois
Modified: 2020-07-01 20:01 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jeandubois 2020-06-04 08:30:49 UTC
Description:
The 'Show tip of the day' button in the 'help' menu and the 'Copy version info' button in 'about LibreOfficeDev' window, button is not translated in the French LibreOffice version. (in version 7.0.0.0.beta1)

Steps to Reproduce:
1. Set the LibreOffice (7.0.0.0.beta1) language to French.
2. Open 'aide' ('help') menu for the 'tip of the day' and 'à propos de LibreOfficeDev' ('about LibreOfficeDev') button for the 'Copy Version Info'.

Actual Results:
The buttons are in English.

Expected Results:
The buttons should be in French.


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: fr
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: yes
Comment 1 jeandubois 2020-06-04 08:37:00 UTC
Oops... I missed to say that the 7.0.0.0.beta1 version is not in the 'libreoffice version' scrolling menu (in BugZilla)... So I say it here. Maybe someone can fix that !
Comment 2 Julien Nabet 2020-06-04 11:30:59 UTC
Thank you Jean Dubois for having spotted this!

On pc Debian x86-64 with master sources updated today, I could reproduce this.
  23202 #. hiZJy
  23203 #: GenericCommands.xcu
  23204 msgctxt ""
  23205 "GenericCommands.xcu\n"
  23206 "..GenericCommands.UserInterface.Commands..uno:TipOfTheDay\n"
  23207 "ContextLabel\n"
  23208 "value.text"
  23209 msgid "Show Tip of the Day"
  23210 msgstr ""
https://translations.documentfoundation.org/languages/fr/libo_ui-master/search/?q=+note%3AhiZJy&checksum=&offset=#

   4068 #. C3pew
   4069 #: cui/uiconfig/ui/aboutdialog.ui:29
   4070 msgctxt "aboutdialog|copy"
   4071 msgid "Copy _Version Info"
   4072 msgstr ""
https://translations.documentfoundation.org/languages/fr/libo_ui-master/search/?q=+note%3AC3pew&checksum=&offset=#

Sophie/Jean-Baptiste: I'd suggest
- "Afficher l'astuce du jour"
- "Copier les informations de la _version de LibreOffice"
I'm adding "LibreOffice" so nobody would think "la version de quoi ?"
"v" is free for using as a shortcut in Help menu in French.

In both cases, I would put uppercase only for the first letter of the first word (except "LibreOffice")
Comment 3 Julien Nabet 2020-06-04 11:31:36 UTC
(Let's put 7.0.0.0 alpha1+ Master for the moment)
Comment 4 sophie 2020-06-04 11:44:42 UTC
Thanks Jean for reporting and for your suggestions, Julien. 
Translation is not finished and we still have some time to do it (until week 29 if I remember well), then it's ok to have English strings in alpha and beta versions. So it's not a bug and I'm closing it.
For the suggestion to add LibreOffice, we should stay vendor neutral, so either there is a variable added to the source string or we let it like that. And you are right that in French we don't capitalize each word but only the first letter of the first word in the sentence :-)
Comment 5 Jean-Baptiste Faure 2020-06-04 11:47:21 UTC
Please, be patient. Translation for current development version is a work in progress.
You can check if the translation in some language is completed here: https://translations.documentfoundation.org/

Currently there are 636 strings left to translate in French.
Please wait until LibreOffice 7.0 is released to report missing translation.
That said reports against incorrect translations are welcome.

Closing as INVALID.

Best regards. JBF
Comment 6 Julien Nabet 2020-06-04 11:53:44 UTC
Thank you Sophie and Jean-Baptiste for your very quick feedback.
Sophie: I had indeed just LO in mind but I suppose Collabora guys wouln't like to patch LO sources for branding reason :-P

Last question for Heiko/Xisco: since strings freeze is planned end of June (see https://wiki.documentfoundation.org/ReleasePlan/7.0), what about replacing
"Copy _Version Info"
by:
"Copy _Version Info of %PRODUCTNAME"
?
Comment 7 Julien Nabet 2020-06-04 12:07:36 UTC
BTW, I supposed "%PRODUCTNAME" was vendor neutral but just thought I might be wrong.
If it's the case, forget my change English string suggestion.
And in this case for French, I'll put on Weblate these
- "Afficher l'astuce du jour"
- "Copier les informations de la _version"
(except if someone disagrees of course).

Also, I forgot to say that I'll put NOTABUG next time for similar reports since indeed, it's quite expected that all the strings haven't been translated yet (mea culpa).
Comment 8 Heiko Tietze 2020-06-05 10:21:49 UTC
(In reply to Julien Nabet from comment #6)
> what about replacing
> "Copy _Version Info"
> by:
> "Copy _Version Info of %PRODUCTNAME"

Would be a quite large button. Better keep it short.
Comment 9 Julien Nabet 2020-06-06 09:32:37 UTC
(In reply to Heiko Tietze from comment #8)
> (In reply to Julien Nabet from comment #6)
> > what about replacing
> > "Copy _Version Info"
> > by:
> > "Copy _Version Info of %PRODUCTNAME"
> 
> Would be a quite large button. Better keep it short.

I disagree here since I would have preferred it more explicit but that's not important.

For the rest, Sophie/Jean-Baptiste are we ok with:
- "Afficher l'astuce du jour"
- "Copier les informations de la _version"
or did you have something else in mind?
Comment 10 Heiko Tietze 2020-06-08 08:51:44 UTC
(In reply to Julien Nabet from comment #9)
> - "Copier les informations de la _version"

Way too long for my taste (check the resulting UI). If we need to shorten text and/or make it more explicit we could use a tooltip.
Comment 11 Julien Nabet 2020-06-08 09:25:41 UTC
(In reply to Heiko Tietze from comment #10)
> (In reply to Julien Nabet from comment #9)
> > - "Copier les informations de la _version"
> 
> Way too long for my taste (check the resulting UI). If we need to shorten
> text and/or make it more explicit we could use a tooltip.

It's the exact French translation from "Copy _Version Info" so changing this to "_Version" + add a tooltip would make it.
Comment 12 Commit Notification 2020-06-16 07:57:19 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d43e03e76e0bcbf1222584c1892d8377b8e09a61

Resolves tdf#133662 - Copy version info reworked

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2020-06-16 13:20:37 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/1c2581ddbdcade6ee55e37e0d05158152820a2d5

Resolves tdf#133662 - Copy version info reworked

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Jean-Baptiste Faure 2020-06-16 14:09:04 UTC
Tooltip says: "Copy all version information in English"

and I get:
Version: 7.0.0.0.beta1+
Build ID: 1c2581ddbdcade6ee55e37e0d05158152820a2d5
Threads CPU : 4; OS : Linux 4.15; UI Render : par défaut; VCL: gtk3
Locale: fr-FR (fr_FR.UTF-8); Langue IHM : fr-FR
Ubuntu_18.04_x86-64
Calc: threaded

which is not in English: "par défaut" and "Langue IHM".

Best regards. JBF
Comment 15 Heiko Tietze 2020-06-16 14:19:37 UTC
(In reply to Jean-Baptiste Faure from comment #14)
> Tooltip says: "Copy all version information in English"

See bug 133775 comment 6.

/off-topic: This about dialog is a honey pot for bike-shedding :-).
(Happy to have things discussed thoroughly).
Comment 16 Jean-Baptiste Faure 2020-06-16 18:40:24 UTC Comment hidden (no-value)
Comment 17 Heiko Tietze 2020-06-17 09:38:24 UTC
(In reply to Jean-Baptiste Faure from comment #16)
> I am sorry, but this bug report is a mess.

Please count the "do/does not" in your post and compare with "I suggest". Read also the discussion on Gerrit, if you want to contribute.

And as an experienced developer you may submit a patch yourself or revert mine.
Comment 18 Commit Notification 2020-06-22 04:29:32 UTC
Ilmari Lauhakangas committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d91dba41d283db9bc83789ca258b1a6001d761ae

tdf#133662 Tweak position of copy version info button

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Commit Notification 2020-06-22 06:43:59 UTC
Ilmari Lauhakangas committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/a3519bbe6afa1a5f8b8c9543bc3fa8e53b145bf6

tdf#133662 Tweak position of copy version info button

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.