Bug 133683 - Values cleared when scrolling in standard filter dialog
Summary: Values cleared when scrolling in standard filter dialog
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: preBibisect, regression
Depends on:
Blocks: Data-Filter
  Show dependency treegraph
 
Reported: 2020-06-04 20:38 UTC by Heather Ellsworth
Modified: 2021-06-04 13:40 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Video showing the reproducer steps and failure (2.02 MB, video/ogg)
2020-06-04 20:39 UTC, Heather Ellsworth
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Heather Ellsworth 2020-06-04 20:38:45 UTC
Description:
The value of an autofiltered column cleared from standard filter when scrolling.

See consistent reproducibility steps and video demonstration.

The issue was produced on both Ubuntu 20.04 and Debian testing with TDF 6.4.4.2 debs.

Steps to Reproduce:
1. Create a spreadsheet with a column of data.
2. Apply autofiltering to the column.
3. Select "standard filter..." from the filter menu.
4. Add a condition (e.g. "Number = 1").
5. Click OK. Data will be filtered as expected.
6. Close the spreadsheet.
7. Open the spreadsheet again.
8. Select "standard filter..." from the filter menu.
9. Scroll down and up again in the filter dialog.

Actual Results:
Field cleared on scroll.

Expected Results:
Field should not be cleared on scroll.


Reproducible: Always


User Profile Reset: No



Additional Info:
Happens in the 6.4.4.2 debs downloaded from TDF's site.

The user that found this issue has also reproduced the issue with git commit 058caeef45f9abf12e4e243aafbbb1c2ebcbc057, which is 7.1.0.0.alpha0+

The original launchpad bug: https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1881811
Comment 1 Heather Ellsworth 2020-06-04 20:39:54 UTC
Created attachment 161621 [details]
Video showing the reproducer steps and failure
Comment 2 Buovjaga 2020-07-06 07:08:47 UTC
This problem did not exist in 3.3.0 (tested on Windows).

In 3.5 and 3.6, you don't even have to scroll - the field is blank upon opening the dialog. The current behaviour started with 4.0

I bibisected the change in behaviour with the Linux 43all repository to the range https://git.libreoffice.org/core/+log/d59024b652ccfaf7247da113ec36788fe260de74..4b4ca8030285bd66526ff5bb2b6ea5a75a6c6bc7

The problem seems to be in the document structure somehow: if I open a filter created with 3.3.0 in 3.5.0, I can see the value in the dialog no matter what I do.
Comment 3 Gabor Kelemen (allotropia) 2021-02-02 07:13:34 UTC
This seems to have been fixed in 7.1 since:

https://git.libreoffice.org/core/+/937b780e3f696552fc686bf0c80c3050443b111a

author	Martin van Zijl <martin.vanzijl@gmail.com>	Wed May 27 08:21:39 2020 +1200
committer	Heiko Tietze <heiko.tietze@documentfoundation.org>	Tue Sep 15 08:40:04 2020 +0200

tdf#76898 standard filter: add buttons to remove conditions
Comment 4 BogdanB 2021-06-04 13:40:05 UTC
it's ok in
Version: 7.2.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: 3b57ebb445df8a2bc3d916ea79f8af45e20e4e62
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: ro-RO (ro_RO); UI: en-US
Calc: threaded