Bug 133706 - FILESAVE DOCX: Header footer text gone after export
Summary: FILESAVE DOCX: Header footer text gone after export
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: DOCX-Header-Footer
  Show dependency treegraph
 
Reported: 2020-06-05 16:33 UTC by Telesto
Modified: 2021-06-02 09:25 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (1.18 MB, application/vnd.oasis.opendocument.text)
2020-06-05 16:34 UTC, Telesto
Details
Minimized document (48.56 KB, application/vnd.oasis.opendocument.text)
2020-06-08 07:21 UTC, NISZ LibreOffice Team
Details
Screenshot of the minimized document in ODT and DOCX format (64.65 KB, image/png)
2020-06-08 07:27 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-06-05 16:33:30 UTC
Description:
FILESAVE DOCX: Header footer text gone after export

Steps to Reproduce:
1. Open the attached file
2. Save to DOCX
3. File -> Reload

Actual Results:
Missing header/footer text

Expected Results:
Should show.. fine with DOC


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 191288d6a7fb52b31038a21c4e71ee57ffa3bacd
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-06-05 16:34:04 UTC
Created attachment 161660 [details]
Example file
Comment 2 NISZ LibreOffice Team 2020-06-08 06:39:13 UTC
Confirming in:

Version: 7.1.0.0.alpha0+ (x64)
Build ID: 75e1cf6c6ea83e65da248dab917b06feea6c18e4
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL
Comment 3 NISZ LibreOffice Team 2020-06-08 06:55:27 UTC
Happens in older versions too: 6.0, 5.0, 4.0 - not a regression.
Comment 4 NISZ LibreOffice Team 2020-06-08 07:21:27 UTC
Created attachment 161752 [details]
Minimized document
Comment 5 NISZ LibreOffice Team 2020-06-08 07:27:39 UTC
Created attachment 161753 [details]
Screenshot of the minimized document in ODT and DOCX format

There are different header styles for the first page and the rest of pages but on export the first page style / content is set for all pages.
Comment 6 Justin L 2020-06-08 18:55:30 UTC
So IsPlausableSingleWordSection is failing because StrictEqualTopBottom is false. The "First page" style has a _slightly_ larger header because the fontsize is 12. The "Default paage" style uses fontsize 10.
Comment 7 Gabor Kelemen (allotropia) 2021-05-27 20:47:08 UTC
This seems to be exported fine in 7.1 since:

https://git.libreoffice.org/core/+/140e8861566afcd1c51ede4bafd9ac2c6192cd68

author	Justin Luth <justin.luth@collabora.com>	Tue Jul 21 21:02:44 2020 +0300
committer	Miklos Vajna <vmiklos@collabora.com>	Wed Jul 22 09:37:48 2020 +0200

tdf#98000 docx export: blank paragraphs don't affect page breaks

Thanks Justin for making this work too :)
Comment 8 BogdanB 2021-06-02 09:25:29 UTC
It's ok now.
Verified in
Version: 7.2.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: 3b57ebb445df8a2bc3d916ea79f8af45e20e4e62
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: ro-RO (ro_RO); UI: en-US
Calc: threaded

Thanks for fixing.