Bug 133730 - Fatal Error: multi_type_vector::position with "enable support for large sheets"
Summary: Fatal Error: multi_type_vector::position with "enable support for large sheets"
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks: Calc-large-spreadsheets
  Show dependency treegraph
 
Reported: 2020-06-06 11:44 UTC by raal
Modified: 2022-02-16 15:10 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
bt with debug symbols (7.21 KB, text/plain)
2020-06-07 09:36 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description raal 2020-06-06 11:44:36 UTC
Description:
Version: 7.0.0.0.beta1+
Build ID: c344de1b9985b6ca10b354e24151d0bdf92dc20e
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: cs-CZ (cs_CZ.UTF-8); UI: en-US
Calc: threaded

Steps to Reproduce:
enable support for large sheets (https://wiki.documentfoundation.org/ReleaseNotes/7.0#Support_for_very_large_spreadsheets)
Open attachment 142401 [details] 
insert sheet after the sheet KROSCEK
wait for long time

Actual Results:
LibreOfficeDev 7.0 - Fatal Error: multi_type_vector::position#1750: block position not found! (logical pos=16000000, block size=2, logical size=1048576)

Expected Results:
sheet inserted


Reproducible: Always


User Profile Reset: No



Additional Info:
.
Comment 1 Telesto 2020-06-07 09:07:51 UTC
I confirm the fatal error

STR for me
1. Open Calc (with support for large sheets"
2. Right Click a column
Comment 2 Julien Nabet 2020-06-07 09:36:26 UTC
Created attachment 161714 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today, I could reproduce the crash described by Telesto.

Here's the last bt retrieved just before error message.
(I used "catch throw")
Comment 3 Julien Nabet 2020-06-07 09:37:11 UTC
Noel: do you think you can fix this or may we need to ping Kohei since it's in mdds?
Comment 4 Telesto 2020-06-07 10:41:44 UTC
Similar issue
1. Open Calc
2. Insert new row. Position #1729
Comment 5 Felix Schwarz 2020-09-21 07:06:39 UTC
still reproducible with latest master (2020-09-20_14.51.16)

Version: 7.1.0.0.alpha0+
Build ID: 40f42f317757ef02d0a4d1cfd1c4f5bd8583e8e0
CPU threads: 12; OS: Linux 5.8; UI render: default; VCL: gtk3
Locale: de-DE (de_DE.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-09-20_14:51:16
Calc: threaded
Comment 6 Timur 2022-01-18 13:59:30 UTC
No repro in 7.4+ for Fatal Error nor crash.
Insert sheet is very long, that's also a bug.
Comment 7 Luboš Luňák 2022-02-14 13:06:12 UTC
I cannot reproduce either.
Slow insert sheet operation is bug #133704.
Comment 8 Julien Nabet 2022-02-14 17:28:27 UTC
On pc Debian x86-64 with master sources updated today, I don't reproduce the Telesto's crash.

About sheet insertion, I must recognize that after a minute, I hadn't the patience to wait for the end.
Comment 9 Xisco Faulí 2022-02-16 15:10:55 UTC
I can't reproduce it in

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 49746f40b06eaf1f61bb54454408a06a49d73c5e
CPU threads: 8; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: es-ES (es_ES.UTF-8); UI: en-US
Calc: threaded Jumbo

Closing as RESOLVED WORKSFORME