Download it now!
Bug 133735 - FILEOPEN: DOCX: Extra spacing in table
Summary: FILEOPEN: DOCX: Extra spacing in table
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: László Németh
URL:
Whiteboard: target:7.1.0 target:7.0.0.2
Keywords: bibisected, bisected, regression
: 133460 (view as bug list)
Depends on:
Blocks: DOCX-Tables
  Show dependency treegraph
 
Reported: 2020-06-06 16:30 UTC by Xisco Faulí
Modified: 2020-07-28 11:23 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Comparison MSO 2010 and LibreOffice 7.1 master (26.19 KB, image/png)
2020-06-06 16:30 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-06-06 16:30:57 UTC
Created attachment 161687 [details]
Comparison MSO 2010 and LibreOffice 7.1 master

Steps to reproduce:
1. Open attachment 91647 [details] from bug 73389

-> The inner table has an extra spacing in first row. See comparison image

Reproducible in

Version: 7.1.0.0.alpha0+
Build ID: 8aee8c0cf1bdda1866594e75b0f9bd4b9a69c724
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: 


[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2020-06-06 16:31:56 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=81ce88aa80f8e7cde4fdc5b211e9500a3599643c

author	László Németh <nemeth@numbertext.org>	2020-05-04 13:42:14 +0200
committer	László Németh <nemeth@numbertext.org>	2020-05-04 17:55:28 +0200
commit	81ce88aa80f8e7cde4fdc5b211e9500a3599643c (patch)
tree	e343d94d8d304e97b82fe42efaabb810b6f3e04f
parent	224c155d89e4d957c0d566a5aea6004a466d54e9 (diff)
tdf#132514 DOCX import: fix lost table style with footer

Bisected with: bibisect-linux64-6.5

Adding Cc: to László Németh
Comment 2 László Németh 2020-07-01 17:00:05 UTC
*** Bug 133460 has been marked as a duplicate of this bug. ***
Comment 3 Commit Notification 2020-07-02 20:17:05 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/45504ca72e0f081de9e7cc4f1faf553c7361694d

tdf#133735 DOCX: fix paragraph settings of nested tables

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2020-07-02 21:46:35 UTC
László Németh committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/aea7fe41358c218a12dc34e4c0942360f0d5fde6

tdf#133735 DOCX: fix paragraph settings of nested tables

It will be available in 7.0.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Xisco Faulí 2020-07-03 16:12:34 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: e2b50a956cd34179d4f1e7f87834a94188011843
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@László Németh, thanks for fixing this issue!!