Download it now!
Bug 133747 - When sorting Japanese Kanji, "時" is the last
Summary: When sorting Japanese Kanji, "時" is the last
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: himajin100000
URL:
Whiteboard: target:7.1.0 target:7.0.1
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-07 06:54 UTC by goma
Modified: 2020-08-05 14:18 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description goma 2020-06-07 06:54:09 UTC
Description:
Calcで日本語の入力されたセルの並べ替えを行うと、『時』から始まる文字列のセルが末尾にソートされる

Steps to Reproduce:
1.Calcで日本語のセルを数行作成する(『時』から始まる文字列も含める)
2.ソートで昇順で並べ替える

Actual Results:
『時』から始まるセルが最後にソートされる

Expected Results:
「じ」から始まる範囲に並べるべき


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
複数のPCで同じ結果が得られた
Comment 1 goma 2020-06-07 06:56:37 UTC
バージョン: 6.4.4.2 (x64)
Build ID: 3d775be2011f3886db32dfd395a6a6d1ca2630ff
CPU threads: 2; OS:Windows 10.0 Build 19041; UI render: default; VCL: win; 
ロケール: ja-JP (ja_JP); UIの言語: ja-JP
Calc: threaded
Comment 2 Julien Nabet 2020-06-07 08:50:47 UTC
Would it be possible you attach an example file?

Himajin100000: thought you might be interested in this one since it may be  Japanese specific.
Comment 4 Julien Nabet 2020-06-07 09:33:47 UTC
Thank you Himajin100000 for your quick feedback. So we need to have feedback from another Japanese native "fluent" with these collation rules.

Takeshi: any thoughts here as a member of Japanese translation team + having contributed in LO code in last years or any idea who may help here?

Eike: if you have some contacts with Japanese people who may have some idea here...
Comment 5 Commit Notification 2020-08-03 20:09:36 UTC
Tomoyuki Kubota committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/71f1623e9c707b2160272bd30a00e16cc3df1c69

tdf#133747 add missing character to make the sort feature work correctly

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2020-08-05 10:28:20 UTC
Tomoyuki Kubota committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/8f464351174d4127b3a165d7e6d33e07b4569862

tdf#133747 add missing character to make the sort feature work correctly

It will be available in 7.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.