Bug 133748 - Slow when switching sheets with "support for large sheets enabled"
Summary: Slow when switching sheets with "support for large sheets enabled"
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected
: 136818 (view as bug list)
Depends on:
Blocks: Calc-large-spreadsheets
  Show dependency treegraph
 
Reported: 2020-06-07 09:01 UTC by Telesto
Modified: 2021-09-06 12:02 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (14.87 MB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2020-06-07 09:02 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-06-07 09:01:46 UTC
Description:
Slow when switching sheets with "support for large sheets enabled"

Steps to Reproduce:
1. Open the attached file
2. Click the Лист1 sheet -> Takes 5-8 seconds.. 

Actual Results:
5-8 seconds

Expected Results:
Instant as without "support for large sheets enabled"


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 191288d6a7fb52b31038a21c4e71ee57ffa3bacd
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-06-07 09:02:17 UTC
Created attachment 161712 [details]
Example file
Comment 2 Roman Kuznetsov 2020-09-16 20:53:10 UTC
in

Version: 7.1.0.0.alpha0+
Build ID: 8c18cd6823ddf4ef5ba67801a84cee26c9b5a9a6
CPU threads: 4; OS: Mac OS X 10.15.6; UI render: default; VCL: osx
Locale: ru-RU (ru_RU.UTF-8); UI: en-US
Calc: threaded

I got a crash with your file (but it's another problem of course, I'll create a new bug report)
Comment 3 Buovjaga 2021-05-07 15:58:14 UTC
Not reproduced, please re-test

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 9df3aa7ea72d61462e430643f2a80906dce4e15b
CPU threads: 2; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: fi-FI (fi_FI); UI: en-US
Calc: threaded Jumbo
Comment 4 Timur 2021-09-06 11:21:03 UTC
Repro 7.1 oldest, but not 7.1 master nor 7.3+. WFM.
Comment 5 Timur 2021-09-06 11:31:40 UTC
Fixed with:

commit fb61e11701002ffb48c0105733dbf0d3c4201666
Date:   Wed Sep 9 21:13:43 2020 +0200
    source sha:94512c499d678e9eeca05e84361d846bbd3b6950
    pre sha:6391e3c4dcd4d61c2f95f996e797e49b5586dbd1

author	Noel Grandin <noelgrandin@gmail.com>	2020-05-26 
committer	Noel Grandin <noel.grandin@collabora.co.uk>	2020-09-09 
sc: rowcol: convert more use of MAXROWCOUNT
this is part of the very large(jumbo) sheet work
Comment 6 Timur 2021-09-06 11:33:35 UTC
*** Bug 136818 has been marked as a duplicate of this bug. ***