Bug 133751 - Crash selecting multiple columns with Support for large sheets enabled
Summary: Crash selecting multiple columns with Support for large sheets enabled
Status: RESOLVED DUPLICATE of bug 133033
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks: Calc-large-spreadsheets
  Show dependency treegraph
 
Reported: 2020-06-07 10:38 UTC by Telesto
Modified: 2020-10-06 16:19 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
bt with debug symbols (5.54 KB, text/plain)
2020-06-07 11:25 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-06-07 10:38:57 UTC
Description:
Crash selecting multiple columns with Support for large sheets enabled

Steps to Reproduce:
1. Open Calc
2. Select column A until L and -> Crash

Actual Results:
Crash

Expected Results:
No crash


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 191288d6a7fb52b31038a21c4e71ee57ffa3bacd
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Julien Nabet 2020-06-07 11:25:22 UTC
Created attachment 161718 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today, I could reproduce this.
Comment 2 Roman Kuznetsov 2020-09-16 20:29:39 UTC
no repro in

Version: 7.1.0.0.alpha0+
Build ID: 8c18cd6823ddf4ef5ba67801a84cee26c9b5a9a6
CPU threads: 4; OS: Mac OS X 10.15.6; UI render: default; VCL: osx
Locale: ru-RU (ru_RU.UTF-8); UI: en-US
Calc: threaded

WFM
Comment 3 Xisco Faulí 2020-10-06 16:19:39 UTC
Issue fixed by
https://cgit.freedesktop.org/libreoffice/core/commit/?id=94512c499d678e9eeca05e84361d846bbd3b6950

*** This bug has been marked as a duplicate of bug 133033 ***