Download it now!
Bug 133753 - "Base point" image in "Position and Size" dialog is missing
Summary: "Base point" image in "Position and Size" dialog is missing
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha1+
Hardware: x86-64 (AMD64) All
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:7.1.0 target:7.0.0.1
Keywords: regression
Depends on:
Blocks:
 
Reported: 2020-06-07 13:30 UTC by Regina Henschel
Modified: 2020-06-27 06:58 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of "Position and Size" dialog (13.46 KB, image/png)
2020-06-07 13:30 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2020-06-07 13:30:07 UTC
Created attachment 161722 [details]
Screenshot of "Position and Size" dialog

The image for "Base point:" in "Position and Size" dialog is missing, see attached screenshot. The hot areas to click are still active, only the image is missing.

I see the error in Version: 7.1.0.0.alpha0+ (x64)
Build ID: 95e5d37b6e62eb39f2d5337e124e86b3d0c3f399
CPU threads: 8; OS: Windows 10.0 Build 18362; UI render: Skia/Vulkan; VCL: win
Locale: de-DE (en_US); UI: en-US
Calc: threaded

and in Version: 7.0.0.0.beta1+ (x64)
Build ID: 900ffff8b5718113e5b3ab7e9fbf35b999661c39
CPU threads: 8; OS: Windows 10.0 Build 18362; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL
Comment 1 Julien Nabet 2020-06-07 14:00:38 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.

I noticed these logs:
warn:vcl:29571:29571:vcl/source/gdi/bitmapex.cxx:111: BitmapEx::BitmapEx(): could not load image svx/res/rectbtns.png via icon theme elementary
warn:vcl:29571:29571:vcl/source/gdi/bitmapex.cxx:111: BitmapEx::BitmapEx(): could not load image svx/res/rectbtns.png via icon theme elementary
Comment 2 Julien Nabet 2020-06-07 14:07:09 UTC
warn:vcl:29897:29897:vcl/source/gdi/bitmapex.cxx:111: BitmapEx::BitmapEx(): could not load image svx/res/rectbtns.png via icon theme sukapura
warn:vcl:29897:29897:vcl/source/gdi/bitmapex.cxx:111: BitmapEx::BitmapEx(): could not load image svx/res/rectbtns.png via icon theme sukapura
Breeze, Colibre, sifr ko too

Karasa theme is ok.

Rizal/Andreas: thought you might be interested in this one since it concerns themes.
Comment 3 Julien Nabet 2020-06-07 14:12:34 UTC
Rizal: I noticed https://cgit.freedesktop.org/libreoffice/core/commit/?id=263e5726c71b3c3579f974194510ed01947ee6cf
Resolves tdf#133268: Update Colibre color palette
- Change color to latest MS Office monoline style
- Overhaul overall appearance

Why deleting icon-themes/colibre/svx/res/rectbtns.png ?

Adolfo: I added you since you were on review. I think this kind of patch needs an extra check.
Comment 4 Rizal Muttaqin 2020-06-07 15:36:13 UTC
(In reply to Regina Henschel from comment #0)
> Created attachment 161722 [details]
> Screenshot of "Position and Size" dialog
> 
> The image for "Base point:" in "Position and Size" dialog is missing, see
> attached screenshot. The hot areas to click are still active, only the image
> is missing.
> 
> I see the error in Version: 7.1.0.0.alpha0+ (x64)
> Build ID: 95e5d37b6e62eb39f2d5337e124e86b3d0c3f399
> CPU threads: 8; OS: Windows 10.0 Build 18362; UI render: Skia/Vulkan; VCL:
> win
> Locale: de-DE (en_US); UI: en-US
> Calc: threaded
> 
> and in Version: 7.0.0.0.beta1+ (x64)
> Build ID: 900ffff8b5718113e5b3ab7e9fbf35b999661c39
> CPU threads: 8; OS: Windows 10.0 Build 18362; UI render: Skia/Vulkan; VCL:
> win
> Locale: en-US (en_US); UI: en-US
> Calc: CL

How to show this dialog?
Comment 5 Rizal Muttaqin 2020-06-07 15:42:21 UTC
(In reply to Julien Nabet from comment #3)
> 
> Why deleting icon-themes/colibre/svx/res/rectbtns.png ?

Simply because there's no SVG equivalent. Will send it later
Comment 6 Regina Henschel 2020-06-07 15:48:55 UTC
And some more:

lftrgt.png and topdown.png in sc/res
They belong to the "Sheet" tab in the page style dialog in Calc.

All fw<number> icons in svx/res are missing.
They belong to the Fontwork-dialog (that from category Format, command Fontwork in Customize...).
Comment 7 Regina Henschel 2020-06-07 16:01:45 UTC
(In reply to Rizal Muttaqin from comment #4)

> How to show this dialog?

Use Draw. Click on a shape, then context menu or short cut F4 or menu Format > Position and Size.
Comment 8 Julien Nabet 2020-06-07 16:43:51 UTC
(In reply to Rizal Muttaqin from comment #5)
> (In reply to Julien Nabet from comment #3)
> > 
> > Why deleting icon-themes/colibre/svx/res/rectbtns.png ?
> 
> Simply because there's no SVG equivalent. Will send it later

But if it's used by some non SVG themes, don't delete it just because there's no SVG equivalent or create the SVG equivalent one.
Comment 9 Regina Henschel 2020-06-07 16:59:53 UTC
*** Bug 133762 has been marked as a duplicate of this bug. ***
Comment 10 Regina Henschel 2020-06-07 18:36:02 UTC
pag-shadow-mask.png from sd/res is missing, screenshots in bug 133762.
Comment 11 Commit Notification 2020-06-07 21:36:18 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/31292d082dbed66fa92e8f17b6a26e43a7928e11

Fix tdf#133753 missing base point, Calc page dialog & Fontwork dialog

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2020-06-07 22:38:10 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/2b051b3375315c15c629c7906dfdf797f48e34b0

Fix tdf#133753 missing base point, Calc page dialog & Fontwork dialog

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2020-06-08 23:48:48 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/4c4b3218b8595a9809ffade0cfd064f3d9335dff

Colibre:tdf#133753 add svx icons

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2020-06-09 05:02:09 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/c46a704943be830d603ba0421a329ccb58b8b209

Colibre:tdf#133753 add svx icons

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Xisco Faulí 2020-06-09 09:40:58 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: e0f058bcd5e185b89e4b7c680a7901bc7eb2a790
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: x11
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Rizal, thanks for fixing this issue!!
Comment 16 Rizal Muttaqin 2020-06-09 10:04:59 UTC
(In reply to Xisco Faulí from comment #15)
> Verified in
> 
> Version: 7.1.0.0.alpha0+
> Build ID: e0f058bcd5e185b89e4b7c680a7901bc7eb2a790
> CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: x11
> Locale: en-US (en_US.UTF-8); UI: en-US
> Calc: threaded
> 
> @Rizal, thanks for fixing this issue!!

That's my obligation who brought the bug.
Comment 17 Commit Notification 2020-06-11 21:41:17 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/26483950760f0aac7bc45e93db4127f66a98fdc6

Sukapura: tdf#133753 Calc left to right images, FontWork dialog image

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2020-06-11 22:35:26 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/642b27448a69f221f3e3bfb387e1a9f8afb9b6b6

Sukapura: tdf#133753 Calc left to right images, FontWork dialog image

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Commit Notification 2020-06-12 14:33:49 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/6c3cd255cece1ed137ed3a143028fdd636e5c3e6

Breeze: tdf#133753: base point,  Calc left to right images

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Commit Notification 2020-06-13 13:14:01 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/b094922d002422ea6872ecc23627f69a4bfc4bb0

Breeze: tdf#133753: base point,  Calc left to right images

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Commit Notification 2020-06-27 04:04:54 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/4842d8f51fe5b6d8b3e8dca559b7fac550f14fbe

Karasa Jaga: tdf#133753, tdf#133582, tdf#106229

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 22 Commit Notification 2020-06-27 06:58:16 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/622bf0d6695e61b73312289a228e29b92ca842b3

Karasa Jaga: tdf#133753, tdf#133582, tdf#106229

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.