Bug 133758 - Handles are no longer semi-transparent
Summary: Handles are no longer semi-transparent
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Rizal Muttaqin
URL:
Whiteboard: target:7.1.0 target:7.0.0.1
Keywords: bibisected, regression
Depends on:
Blocks: Icon-Theme-Colibre
  Show dependency treegraph
 
Reported: 2020-06-07 15:55 UTC by Regina Henschel
Modified: 2020-06-15 01:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
correct semitransparent handle (1.46 KB, image/png)
2020-06-07 15:55 UTC, Regina Henschel
Details
wrong opak handle (725 bytes, image/png)
2020-06-07 15:55 UTC, Regina Henschel
Details
Galaxy object handler (10.53 KB, image/png)
2020-06-13 22:08 UTC, Rizal Muttaqin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2020-06-07 15:55:13 UTC
Created attachment 161729 [details]
correct semitransparent handle

The handles which are used to resize an object are no longer semitransparent. That makes exact working with mouse impossible. I'll attach screenshots of correct old behavior and wrong new behavior.
Comment 1 Regina Henschel 2020-06-07 15:55:46 UTC
Created attachment 161730 [details]
wrong opak handle
Comment 2 Telesto 2020-06-10 05:22:26 UTC
Seen thst too
Comment 3 Buovjaga 2020-06-13 15:57:47 UTC
Bibisected with win 7.1 repo to range https://git.libreoffice.org/core/+log/1aa9a2ac5341d457bbdc00b987285203d11333f1..b5cb211f80fd87c109633232cf340ac7969c8648

I guess it is one of the icon changes.
Comment 4 Rizal Muttaqin 2020-06-13 22:04:58 UTC
I could not see transparency in Galaxy icon theme. Is this really really needed?
Comment 5 Rizal Muttaqin 2020-06-13 22:08:28 UTC
Created attachment 161969 [details]
Galaxy object handler

I talked about Galaxy since it is official OpenOffice.org icon theme for a long time.
Comment 6 Regina Henschel 2020-06-13 23:42:03 UTC
(In reply to Rizal Muttaqin from comment #4)
> I could not see transparency in Galaxy icon theme. Is this really really
> needed?

The handles in the image, which you have attached, are semi-transparent. Semi-transparent markers exists as least since LO 4.0.

And yes, it is needed.

We had a similar issue earlier, bug 119249.
Comment 7 Rizal Muttaqin 2020-06-14 09:52:54 UTC
(In reply to Regina Henschel from comment #6)
> (In reply to Rizal Muttaqin from comment #4)
> > I could not see transparency in Galaxy icon theme. Is this really really
> > needed?
> 
> The handles in the image, which you have attached, are semi-transparent.
> Semi-transparent markers exists as least since LO 4.0.
> 
> And yes, it is needed.
> 
> We had a similar issue earlier, bug 119249.

Ah yes, I missed that since Galaxy has less transparency than legacy Colibre. How transparent it should be?
Comment 8 Commit Notification 2020-06-15 00:26:00 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b73abf0e58e6c1b17e44b171d8144de2bdf9d2e5

Colibre:tdf#133758 make handles semi-transparent again

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2020-06-15 01:39:28 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/27922582da61455f91e62c4a36bd79e667aa7195

Colibre:tdf#133758 make handles semi-transparent again

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.