Bug 133796 - [EDITING] Scroll Lock mode fails for horizontal cursor keys, when there are frozen rows and columns
Summary: [EDITING] Scroll Lock mode fails for horizontal cursor keys, when there are f...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: implementationError
Depends on:
Blocks: Scrolling-PageUpDown Cell-Freeze
  Show dependency treegraph
 
Reported: 2020-06-08 16:11 UTC by zzz
Modified: 2020-10-30 13:28 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
20201030ScrollLockBug.ods reproducible data (11.05 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-10-30 10:11 UTC, zzz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zzz 2020-06-08 16:11:15 UTC
When I turn on the Scroll Lock key, up/down arrow key correctly scrolls the sheet down/up. But left/right arrow key is ignored and nothing happens, where it should make the sheet scroll right/left (or at least move the cursor left/right instead).
Or preferably, adding new keyboard shortcuts for "scroll sheet with cursor position fixed" operations would be even better because the Scroll Lock mode toggling has its own unpleasant side-effects. A nice key assignment would be right-ctrl+arrow or ctrl+tenkeyarrow (again hopefully reconfigurable, and default off, for people who don't like it).
Comment 1 Buovjaga 2020-10-17 12:37:06 UTC
It works fine for me. Can you test with version 7?

Version: 7.1.0.0.alpha0+ (x64)
Build ID: df74aef7159d7155addf78cfc4d139485945d794
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: default; VCL: win
Locale: fi-FI (fi_FI); UI: en-US
Calc: threaded

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 2 zzz 2020-10-30 10:11:05 UTC
Created attachment 166869 [details]
20201030ScrollLockBug.ods reproducible data
Comment 3 zzz 2020-10-30 10:14:17 UTC
Found one condition.
Set the View | Freeze Rows and Columns to ON.

Reproduced at following environment:
Version: 7.0.1.2 (x64)
Build ID: 7cbcfc562f6eb6708b5ff7d7397325de9e764452
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win
Locale: ja-JP (ja_JP); UI: en-US
Calc: threaded
Comment 4 Buovjaga 2020-10-30 13:28:44 UTC
Reproduced with file. The behaviour has been the same since scroll lock scrolling was implemented with bug 46200

Version: 7.1.0.0.alpha1+ (x64)
Build ID: b61bf7c7cfcf97a5ade6d130873af146670bc2ee
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: default; VCL: win
Locale: fi-FI (fi_FI); UI: en-US
Calc: threaded