Bug 133803 - Crash in: URLBox::URLBox FILESAVE
Summary: Crash in: URLBox::URLBox FILESAVE
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Save
  Show dependency treegraph
 
Reported: 2020-06-08 18:57 UTC by Gerald Clement
Modified: 2022-01-04 19:57 UTC (History)
3 users (show)

See Also:
Crash report or crash signature: ["URLBox::URLBox"]
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald Clement 2020-06-08 18:57:50 UTC
This bug was filed from the crash reporting server and is br-a6df0975-7a8f-45c0-818f-c0d4b0488d4e.
=========================================
This is the 2nd time I have updraded to 6.4 LO from 6.3.  Both 6.43 & 6.44 CALC crash on simple tasks.  This case, I copied some delimited data from a web page and pasted into Calc, formated it, cleaned it up and when I tried to save it CRASH!  Several times over & over.  I will go back to 6.3 and not have the problem.
Comment 1 Julien Nabet 2020-06-09 07:17:52 UTC
Could you be more precise? What web page, what part... ?
Comment 2 Xisco Faulí 2020-06-09 11:54:56 UTC
Thank you for reporting the bug. To be certain the reported issue is not related to corruption in the user profile, could you please reset your Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the issue is still present
Comment 3 Gerald Clement 2020-06-09 18:33:23 UTC
A simple process done from countless other websites but in this case was census data: columns of text and numbers a page deep.  Highlight the text and numbers,
copy, paste into a blank spreadsheet which populates the data into the cells, select all cells in the spreadsheet, clear all direct formatting, reset the font size, center some columns, save and crash.  I've tried saving at different points in this process with the same result.  This happened in version 6.4.3 & 6.4.4.  It DOES NOT HAPPEN in versions 6.3.4.2 and earlier versions I have used.  I have rolled back to 6.3.4.2 to continue working.
Comment 4 QA Administrators 2020-06-10 03:49:44 UTC Comment hidden (obsolete)
Comment 5 Buovjaga 2020-10-26 17:05:39 UTC
(In reply to Gerald Clement from comment #3)
> A simple process done from countless other websites but in this case was
> census data: columns of text and numbers a page deep.  Highlight the text
> and numbers,
> copy, paste into a blank spreadsheet which populates the data into the
> cells, select all cells in the spreadsheet, clear all direct formatting,
> reset the font size, center some columns, save and crash.  I've tried saving
> at different points in this process with the same result.  This happened in
> version 6.4.3 & 6.4.4.  It DOES NOT HAPPEN in versions 6.3.4.2 and earlier
> versions I have used.  I have rolled back to 6.3.4.2 to continue working.

Can you point us to the exact website you used? I won't set to needinfo because there is a crash report.
Comment 6 Xisco Faulí 2021-07-07 10:44:03 UTC
Hello Gerald,
Could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version.
Comment 7 QA Administrators 2022-01-04 03:30:06 UTC Comment hidden (obsolete)
Comment 8 Gerald Clement 2022-01-04 19:50:39 UTC
Since I have upgraded to Mint 20 and LibreOffice 7.241 I have not experienced this bug any further.

This has likely been resolved with newer versions but I have no further info I can provide.

Reviewing the information I provided earlier does not seem to leave out any further information I could provide.

If this bug was unique to me I have no explanations.
Comment 9 Gerald Clement 2022-01-04 19:51:30 UTC Comment hidden (obsolete)
Comment 10 Julien Nabet 2022-01-04 19:57:39 UTC
Let's put this one to WFM then.