Download it now!
Bug 133821 - Font, style selectors on toolbar mis-rendered with RTL-language UI
Summary: Font, style selectors on toolbar mis-rendered with RTL-language UI
Status: RESOLVED DUPLICATE of bug 133822
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.0.0.0.beta1+
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTL-UI
  Show dependency treegraph
 
Reported: 2020-06-09 11:45 UTC by eladhen2
Modified: 2020-06-09 14:19 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
A screenshot showing the misaligned style and font boxes. (88.21 KB, image/png)
2020-06-09 11:47 UTC, eladhen2
Details

Note You need to log in before you can comment on or make changes to this bug.
Description eladhen2 2020-06-09 11:45:51 UTC
Description:
The font and style fields are drawn incorrectly when interface language is set to an RTL language.

Steps to Reproduce:
1. Start LO 7
2. Set interface language to Hebrew or another RTL language
3. observe the toolbar, and specifically the font and style fields.

Actual Results:
The font and style fields are drawn incorrectly. They are drawn as if aligned to the left. See attached screenshot

Expected Results:
The font and style fields should match the RTL interface.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
running on Linux Mint 18.3
Comment 1 eladhen2 2020-06-09 11:47:15 UTC
Created attachment 161805 [details]
A screenshot showing the misaligned style and font boxes.

A screenshot showing the misaligned style and font boxes.
Comment 2 Eyal Rozenberg 2020-06-09 12:03:39 UTC
Confirmed with:

Version: 7.0.0.0.beta1
Build ID: 94f789cbb33335b4a511c319542c7bdc31ff3b3c
תהליכי משנה במעבד: 4; מערכת הפעלה: Linux 5.2; עיבוד מנשק: בררת מחדל; VCL: gtk3
Locale: en-US (en_IL); UI: he-IL
Calc: threaded
Comment 3 Xisco Faulí 2020-06-09 14:19:33 UTC
we can close it as duplicate of bug 133822 since https://gerrit.libreoffice.org/c/core/+/95951 also fixes it

*** This bug has been marked as a duplicate of bug 133822 ***