Bug 133829 - Section names not listed while adding a section from another document.
Summary: Section names not listed while adding a section from another document.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Section
  Show dependency treegraph
 
Reported: 2020-06-09 16:54 UTC by bvidinli
Modified: 2020-06-14 17:06 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample document on my system (14.60 KB, application/vnd.oasis.opendocument.text)
2020-06-13 15:54 UTC, bvidinli
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bvidinli 2020-06-09 16:54:28 UTC
Description:
Using Ubuntu, Libreoffice 6.4.3.2

I have a document, where there are sections in it. 

I want to use those sections from a second document. 

In second document, I click insert-> section, 
Click "link", choose a file. 
The sections in choosen file should be listed in dropdown. But, it does not list. 

If I write section name from other document manually, it inserts as expected. 


Actual Results:
No sections listed in dropdown

Expected Results:
.


Reproducible: Always


User Profile Reset: No



Additional Info:
.
Comment 1 Dieter 2020-06-12 07:21:58 UTC
I can't confirm it with

Version: 7.1.0.0.alpha0+ (x64)
Build ID: 41d8b41767032681a9897b7551f011d450e3725e
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: threaded

Sections are shown in dropdown list.

To be certain the reported issue is not related to corruption in the user profile, could you please reset your Libreoffice profile (https://wiki.documentfoundation.org/UserProfile) and re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the issue is still present.
Comment 2 bvidinli 2020-06-12 17:22:00 UTC
I retested in safe mode (Profile resetted).
Same problem persists on my side. 
I am ready to provide any requested info/logs. 

Thanks.
Comment 3 bvidinli 2020-06-12 17:24:40 UTC
OS: Ubuntu 20.04

Sürüm: 6.4.3.2
İnşa №: 1:6.4.3-0ubuntu0.20.04.1
İşlemci süreçleri: 8; İşletim Sistemi:Linux 5.4; UI gerçekleyici: varsayılan; VCL: gtk3; 
Yerel: tr-TR (tr_TR.UTF-8); Arayüz Dili: tr-TR
Calc: threaded
Comment 4 Dieter 2020-06-13 08:23:27 UTC
(In reply to bvidinli from comment #2)
> I am ready to provide any requested info/logs. 
> 
> Thanks.

Could you please add a sample document with sections, so I can try to reproduce with that document? Thanks.
Comment 5 bvidinli 2020-06-13 15:54:57 UTC
Created attachment 161955 [details]
Sample document on my system
Comment 6 Dieter 2020-06-14 08:14:32 UTC
I've tested with your file. Still can't reproduce it with

Version: 7.0.0.0.beta1 (x64)
Build ID: 94f789cbb33335b4a511c319542c7bdc31ff3b3c
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

but reproducible with

Version: 6.4.4.2 (x64)
Build-ID: 3d775be2011f3886db32dfd395a6a6d1ca2630ff
CPU-Threads: 4; BS: Windows 10.0 Build 18363; UI-Render: GL; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded

So it seems to be fixed in LO 7. So could you please try with beta version of LO 7? You can download it here: https://www.libreoffice.org/download/download/?type=win-x86_64&version=7.0.0 You can install it alongside the standard version. I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in Beta version or change it to WORKSFORME
Comment 7 bvidinli 2020-06-14 17:06:17 UTC
Works on Beta Version 7
Thanks. 

(This was actually working on previous versions also... I had used it)