Bug 133858 - opening spreadsheet with large array formula takes 10 mins
Summary: opening spreadsheet with large array formula takes 10 mins
Status: ASSIGNED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All Linux (All)
: medium normal
Assignee: Noel Grandin
URL:
Whiteboard: target:7.2.0 target:7.1.1
Keywords: perf
Depends on:
Blocks:
 
Reported: 2020-06-10 11:43 UTC by Noel Grandin
Modified: 2021-02-08 11:48 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Noel Grandin 2020-06-10 11:43:58 UTC
Description:

This spreadsheet has lots of formulas that do SUM(IF... over a whole column.

The spreadsheet takes 5 min to load on my machine on current master.

This is an internal Collabora bug and the document is not shareable.


Actual Results:
 

Expected Results:
 


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Commit Notification 2020-06-10 18:44:35 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/9a5f2961b085ce2f23ecdf0a03d1114bacac8e2c

tdf#133858 opening spreadsheet with large array formula takes 10 mins

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 2 Commit Notification 2020-06-11 06:44:22 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/44a56e277f7e4d222767fa82f0bce2e7f51be6ca

tdf#133858 opening spreadsheet with large array formula takes 10 mins

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Joel Madero 2020-06-24 15:27:28 UTC
The solution for this bug created a much more serious issue (see tdf#134234). I think it needs to be reverted.
Comment 4 Commit Notification 2020-06-25 07:24:33 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/6f151be2994b0e78a890c13ccdd9249f1800c6de

Revert "tdf#133858 opening spreadsheet with large array formula takes 10 mins" (tdf#134234)

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2020-06-25 09:55:13 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/e2ec8e1f3fac6fc0a426b5735ad21371c68760ae

Revert "tdf#133858 opening spreadsheet with large array formula takes 10 mins" (tdf#134234)

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Roman Kuznetsov 2020-06-25 19:58:03 UTC
set to NEW by Comment 5
Comment 7 Commit Notification 2021-01-14 09:48:24 UTC
Dennis Francis committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b14107dd0eaf9bfc276544e1900873d36075425e

tdf#133858 reduce the double-ref range to data content

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Cor Nouws 2021-02-05 09:32:06 UTC
(In reply to Commit Notification from comment #7)
> Dennis Francis committed a patch related to this issue.
> ... 
> Affected users are encouraged to test the fix and report feedback.
Tested in 
Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: 947277146e4c1ff7544371095fcc6bd5842b2d98
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: nl-NL (en_US.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2021-02-02_19:17:41
Calc: threaded

and works great. Thanks :) !
Comment 9 Xisco Faulí 2021-02-05 09:34:37 UTC
Hi Cor,
Should it be closed as VERIFIED FIXED ?
Comment 10 Cor Nouws 2021-02-05 10:50:40 UTC
Hi Xisco -- missing FOSDEM too ?  :( --
I didn't touch since it is still assigned. Maybe for backporting to 7.0 or 7.1?
But for me, it would of course be OK ;)
Comment 11 Commit Notification 2021-02-08 11:48:23 UTC
Dennis Francis committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/98ae69664918348199f5b524005ae9460e3dad58

tdf#133858 reduce the double-ref range to data content

It will be available in 7.1.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.