Download it now!
Bug 133862 - Crash when trying to customize toolbar during embedded Equation editing
Summary: Crash when trying to customize toolbar during embedded Equation editing
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.4.0.3 release
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.1.0 target:7.0.0.1 target:6.4.5
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-06-10 13:35 UTC by NISZ LibreOffice Team
Modified: 2020-06-14 19:51 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2020-06-10 13:35:15 UTC
Attached document contains a simple equation. Trying to edit this changes the UI to equation editing. Selecting View – Toolbars – Customize crashes Writer (but Calc too) instead of showing the Customize dialog.

Console shows this error message in bibisect-win64-6.4 at :

I/O warning : failed to load external entity "file:///C:/Users/kelemengabo/cygwin/home/kelemengabo/bibisect-win64-6.4/instdir/program/../user/config/soffice.cfg/modules/s/ui/"

Steps to reproduce:
    1. Select Insert -> Object -> Formula
    2. Select View ->Toolbars ->Customize

Actual results:
Crash.

Expected results:
Customize dialog opens, like when the cursor is in the document body.

LibreOffice details:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 59939d2490726336546c7ad05082d23031074e12
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL

Started to happen in
Version: 6.4.0.3 (x86)
Build ID: b0a288ab3d2d4774cb44b62f04d5d28733ac6df8
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: CL

But not yet in:
Verzió: 6.3.0.4 (x86)
Build az.: 057fc023c990d676a43019934386b85b21a9ee99
CPU szálak: 4; OS: Windows 6.3; Felületmegjelenítés: alapértelmezett; VCL: win; 
Területi beállítások: hu-HU (hu_HU); Felület nyelve: hu-HU
Calc: CL

Bibisected using bibisect-win64-6.4 to:

URL: https://cgit.freedesktop.org/libreoffice/core/commit/?id=7d9ff70206dbd75a7751515b642fbbbc8878c15
author	Sumit Chauhan <sumitcn25@gmail.com>	2019-06-17 21:54:27 +0530
committer	Szymon Kłos <szymon.klos@collabora.com>	2019-06-18 11:22:22 +0200
summary: User directory path changed
Comment 1 Xisco Faulí 2020-06-10 13:54:17 UTC
Reproduced in

Version: 7.1.0.0.alpha0+
Build ID: be5dc50d551afe6064b1b64d0470ae5e250acd1c
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 3 Xisco Faulí 2020-06-10 14:30:52 UTC
Hi Caolán,
since you fixed bug 133036, I thought you might be interested in this issue...
Comment 4 Commit Notification 2020-06-11 08:02:48 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/8ee43bb5a75b3ae4488d3373511eaf001674fc71

Resolves: tdf#133862 crash in customize toolbar in embedded math

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2020-06-11 08:04:18 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/82b46d1683a0817583e8749b4076082b2de6782b

Resolves: tdf#133862 crash in customize toolbar in embedded math

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Caolán McNamara 2020-06-11 08:05:59 UTC
fixed in master and 7-0, backport to 6-4 in gerrit
Comment 7 Xisco Faulí 2020-06-11 08:49:33 UTC
Verified in a local build.
@Caolán, thanks for fixing this issue!!
Comment 8 Commit Notification 2020-06-11 08:51:32 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/0e30ed655c6c893502bfc3de26427d0b99857561

Resolves: tdf#133862 crash in customize toolbar in embedded math

It will be available in 6.4.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2020-06-11 14:25:20 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/4407ee148ca5b44a66b212b9c89d9f0e602f0f00

tdf#133862: sw: Add UItest

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2020-06-12 19:33:17 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4-5":

https://git.libreoffice.org/core/commit/60b9663864cd8350840196c24388c467fb170260

Resolves: tdf#133862 crash in customize toolbar in embedded math

It will be available in 6.4.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.