Bug 133892 - select a range from heading-A to heading-B's end, using Navigator
Summary: select a range from heading-A to heading-B's end, using Navigator
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Selection
  Show dependency treegraph
 
Reported: 2020-06-11 11:03 UTC by peter josvai
Modified: 2020-08-13 12:33 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
text selection using shift+arrow/page keys and headings content navigation view multi-selection (4.71 MB, video/x-matroska)
2020-08-12 22:07 UTC, Jim Raykowski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description peter josvai 2020-06-11 11:03:17 UTC
to be able to safely select a range of text has been a dream since ever...

when you have to keep "shift" pressed and scroll at the same time, over dozens of pages, although you can keep it all under control, you have left the convenience zone of using Writer :)

it would be such a great thing to be able to select text between point-A and point-B..

my original suggestion would have been this:
let the user place an anchor somewhere, a temporary "bookmark" (which will be flushed when another such bookmark is being placed in the body of the document), and use "right click" somewhere else and select all the text between the two points...

BUT...
this is something which some people would LOVE... while essentially, this extra functionality does NOT really belong to the realm of Writing...

for most people it would be a superfluous thing, and those who use it would NOT be typical users of Writer...

:::: the actual suggestion:

this other suggestion, whoever, could be great help for anyone writing and editing longer texts...

the user should be able to select a range in NAVIGATOR ! :) 
and cut or copy or delete that amount of text...

Now, that it's being done through the Navigator panel, 
it all of a sudden makes sense, cause in this mode you're editing the text at a 
wide scope... you're not working on a paragraph, but editing the whole of the text... moving entire chapters under headings...

this amount of control even seems reasonable for someone looking at the Navigator panel.. :) cause whenever we see some text, we assume that it can be edited by selecting and cutting , for example :)

in any case, this would be a HUGE thing, I believe...
the only problem could be, virtually, that Navigator, once again, is facing a possible trangsression :)

PS:
an argument supporting the idea:
the "excel" part of Libreoffice already has it, or at least it has been asked for (according to a glance at some google search results)

and if it is NATURAL to seek a way to select multiple rows in a spreadsheet, that CALC users can have it, how could it be denied of writers, working on their texts, at the same time? :)



- - - thank you for developing Libreoffice & Writer - - -
Comment 1 Dieter 2020-08-12 16:16:28 UTC
cc: Design-Team for further input and decision

cc: Jim Raykowski (perhaps he knows if such a feature would be possible)
Comment 2 Jim Raykowski 2020-08-12 22:07:14 UTC
Created attachment 164224 [details]
text selection using shift+arrow/page keys and headings content navigation view multi-selection

In version 7.0 and above there is opportunity to delete multiple chapters in Navigator Headings Content Navigation View using list multi-selection techniques, e.g. shift+arrow up/down, ctrl/shift + mouse click, and then either pressing the 'Del' key or from the context menu item 'Delete'.

Since version - I don't know - text selection can be accomplished by many keyboard methods, e.g. Shift + arrow/page keys.

Please see attached video demo.

Perhaps I misunderstand what is being asked for enhancement?
Comment 3 Heiko Tietze 2020-08-13 11:43:11 UTC
(In reply to Jim Raykowski from comment #2)
> In version 7.0 and above there is opportunity to delete multiple chapters in
> Navigator Headings Content Navigation View

And selection works of course too. So WFM.
Comment 4 Dieter 2020-08-13 12:33:05 UTC
(In reply to Jim Raykowski from comment #2)
> Created attachment 164224 [details]
> text selection using shift+arrow/page keys and headings content navigation
> view multi-selection
> 
> In version 7.0 and above there is opportunity to delete multiple chapters in
> Navigator Headings Content Navigation View using list multi-selection
> techniques, e.g. shift+arrow up/down, ctrl/shift + mouse click, and then
> either pressing the 'Del' key or from the context menu item 'Delete'.
> 
> Since version - I don't know - text selection can be accomplished by many
> keyboard methods, e.g. Shift + arrow/page keys.
> 
> Please see attached video demo.
> 
> Perhaps I misunderstand what is being asked for enhancement?

Thanks for this information. I think, documentation about Content Navigation View could be improved here: https://help.libreoffice.org/7.0/en-GB/text/swriter/01/02110000.html?&DbPAR=WRITER&System=WIN