Bug 133904 - Crash swlo!SwLayoutFrame::ContainsContent+0x3f:
Summary: Crash swlo!SwLayoutFrame::ContainsContent+0x3f:
Status: RESOLVED DUPLICATE of bug 134965
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 134966 (view as bug list)
Depends on:
Blocks: Crash
  Show dependency treegraph
 
Reported: 2020-06-11 18:05 UTC by Telesto
Modified: 2022-02-03 09:49 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-06-11 18:05:37 UTC
Description:
Crash swlo!SwLayoutFrame::ContainsContent+0x3f:

Steps to Reproduce:
1. Open attachment 161893 [details] (ODT from bug 133897)
2. CTRL+A
3. CTRL+C
4. CTRL+N
5. CTRL+V -> wait & crash

Actual Results:
Crash

Expected Results:
No crash


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: a201ab6f47c2d5a7ba4c5f998b0aa231cae82010
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 MM 2020-06-12 19:44:07 UTC
Confirmed on mint 19.3 with Version: 7.1.0.0.alpha0+
Build ID: 20ba8d8d9f4fcf7d5826fcb3366a9bff0d6a8ca1
CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-06-10_07:16:41
Calc: threaded


Confirmed with Version: 7.0.0.0.alpha1+
Build ID: f2561331534459f8aebc57e8615fa5f626521bcb
CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-05-24_14:20:49
Calc: threaded


crashreport.libreoffice.org/stats/crash_details/67e9d034-e104-41cb-af15-beb53055ee09

Unconfirmed with Version: 6.0.7.3
Build ID: 1:6.0.7-0ubuntu0.18.04.10
CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc:
Comment 2 Buovjaga 2020-06-13 14:43:52 UTC
Bibisected with Linux 6.4 repo to https://git.libreoffice.org/core/+/1cb7e4899b5ada902e99a0c964ee047950c07044%5E!/
sw: avoid deleting the iterated SwRowFrame on tdf104188-4.odt

Adding Cc: to Michael Stahl
Comment 3 libre officer 2020-06-14 13:31:58 UTC
Confirmed crash:

Version: 6.4.1.2 (x86)
Build ID: 4d224e95b98b138af42a64d84056446d09082932
CPU threads: 4; OS: Windows 10.0 Build 17763; UI render: default; VCL: win; 
Locale: fr-CH (fr_FR); UI-Language: en-GB
Calc: CL

https://crashreport.libreoffice.org/stats/crash_details/0436577a-fe33-4837-b07e-281caea79cd2

Confirmed crash:

Version: 6.4.3.2 (x64)
Build ID: 747b5d0ebf89f41c860ec2a39efd7cb15b54f2d8
CPU threads: 4; OS: Windows 10.0 Build 17763; UI render: default; VCL: win; 
Locale: fr-CH (fr_FR); UI-Language: en-US
Calc: threaded

https://crashreport.libreoffice.org/stats/crash_details/7b430f87-b9f2-4a05-8288-874ee573a97a

Confirmed crash:

Version: 7.0.0.0.beta1 (x64)
Build ID: 94f789cbb33335b4a511c319542c7bdc31ff3b3c
CPU threads: 4; OS: Windows 10.0 Build 17763; UI render: Skia/Raster; VCL: win
Locale: fr-CH (fr_FR); UI: en-GB
Calc: threaded

https://crashreport.libreoffice.org/stats/crash_details/fd4cc5cb-8e5f-48a4-b40b-71d30ebf7ab1
Comment 4 Telesto 2020-07-25 19:06:56 UTC
*** Bug 134966 has been marked as a duplicate of this bug. ***
Comment 5 Xisco Faulí 2021-02-09 14:25:49 UTC
Dear Michael Stahl,
This bug has been in ASSIGNED status for more than 3 months without any
activity. Resetting it to NEW.
Please assign it back to yourself if you're still working on this.
Comment 6 Telesto 2021-10-29 07:03:12 UTC
No crash for me
Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 93115d2c54d645bcf2f80fde325e3ede39dee4d5
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL

@Buovjaga 
Do you confirm?
Comment 7 Buovjaga 2021-11-05 17:03:08 UTC
Yep, it's gone

Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 7cd5b35caa8d4fa9d0ba2b2c6ce4b88726ed2be6
CPU threads: 2; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: fi-FI (fi_FI); UI: en-US
Calc: threaded
Comment 8 Gabor Kelemen (allotropia) 2022-02-03 09:49:27 UTC
Seems to have been fixed in 7.1 by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=aed92491f356b008fe1cd25b5cd6cc43279db3a3

author	Michael Stahl <Michael.Stahl@cib.de>	2020-07-31 14:46:13 +0200
committer	Michael Stahl <michael.stahl@cib.de>	2020-07-31 16:31:00 +0200
commit aed92491f356b008fe1cd25b5cd6cc43279db3a3 (patch)

tdf#134965 sw: avoid RemoveFollowFlowLine() SNAFU

*** This bug has been marked as a duplicate of bug 134965 ***